Support » Fixing WordPress » Issue after WP4.2: can't add new post or pages

  • Resolved PenelopeGlamour

    (@penelopeglamour)



    Hi everybody.
    I was fixing some broken images in my blog (a dummy issue with special caracters in filenames) when I’ve discover that I can’t add new post or pages.

    Two days ago I moved my site from one hosting to another and I’ve hav a problem with my photos. After move the site, I updated my blog and forgot until today, when I was fixing that problem.

    What’s hapened? When I clcikn on Add new both post and pages, I have this message:

    You are currently editing the page that shows your latest posts.

    I’m administrator of the site.

    I’ve tried:
    turn off all plugins: not work
    login with another user (redactor): dont work
    change theme to twenty twelve: dont work

    I dont know if is an issue because the update or other thing (because I was changing the hosting, fixing images…) but I think It could be.

    WP 4.2
    Theme I’m using: a child theme for hueman theme (But is not a new one, I have working from… 3 month ago)
    Plugins:
    Akismet
    Async JS and CSS
    Cookie Law Info
    Easy Recipe Plus
    Eggplant 301 Redirects
    FV Top Level Categories
    Google Analytics af Yoast
    Nelio Featured Posts
    NextScripts: Social Networks Auto-Poster
    Relevanssi
    TinyMCE Advanced
    W3 Total Cache
    Wordfence Security
    WordPress SEO
    WP-PageNavi

    and two more of my own.

    By the way, the page seems works “fine”: frontpage works fine, I can edit posts and pages… could be some in the database? some kind of block to new records or something in that way.

    Thanks a lot

Viewing 5 replies - 1 through 5 (of 5 total)
  • Ok, I’ve got it. Ther was a error in database, table wp_post havent primary key, I dont know why… maybe I did something wrong

    Hey , how did you fix it ? thanks

    Hi hibestnick, I went into the database (you can access to yours with phpmyadmin, for example. Ask to your hosting support) and modify the wp_post table adding the primary key to de “id” field:

    alter table wp_post add primary key (id)

    http://www.w3schools.com/sql/sql_primarykey.asp

    I hope this help you, I cant explain better

    Hi PenelopeGlamour,

    Just want to thank you for sharing your fix, the missing indexes from the tables were also what were wrong in a site I was editing.

    Thanks!!

    Hi Alesub,
    I have solved the issued by installing the WP-DB Manager and repair the wp-post tables. And now it is working fine.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Issue after WP4.2: can't add new post or pages’ is closed to new replies.