Support » Plugin: Simple Lightbox » Isn’t this supposed to work ‘out of the box’?

  • Resolved cambofrizz

    (@cambofrizz)


    I have individual image links, and I have a standard WordPress gallery and none of those work to pop up in a lightbox, as promised by this plug-in. The link simply opens up the full image url. I have no idea what I’m missing.

    And I have a standard WP install, with a standard theme (TwentyTwenty) and no other plug-ins active. Working on localhost, so cannot give you a link.

    • This topic was modified 6 months ago by cambofrizz.
Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Archetyped

    (@archetyped)

    When activated and enabled, SLB automatically displays standard image and gallery links in a lightbox when clicked.

    Without a URL to evaluate directly, more information is required, especially since “localhost” can mean a lot of different things:

    • What platform is used to serve the WP site? (WAMP/MAMP, Docker, Local, etc.)
    • What versions of PHP, MySQL, and WordPress are being used?
    • Are any custom configuration settings used by the HTTP server, PHP, etc. of the local server? If so, please provide details.
    • Is the WP site’s URL set to localhost or something else? (custom URI, port number, etc.)
    • Does the local site meet SLB’s requirements?
    • Screenshot if SLB’s admin settings page

    Thanks.

    Thread Starter cambofrizz

    (@cambofrizz)

    Thank you for the quick response. I’d like to point out I have been developing on localhost for a long time and never encountered any theme, plug-in or other functionality not working because of that. In the case of lightbox plugins, I’ve tested quite a few, but I’m looking for a plug-in that I can easily adjust to my needs. That’s why I wanted to test SLB, but it’s the only one that doesn’t do what it’s supposed to do.

    Anyway, since you asked:

    Platform: Laragon
    PHP version: 7.4.3
    MySQL version: 5.7.24
    WordPress version: 5.5.1
    The site is set to a custom URI mapped in the hosts file to localhost

    The site meets all of WP’s requirements and thus SLB’s requirements.
    I don’t think I can upload a screenshot here, but SLB’s settings are all default ones. I tried other settings, but nothing changed, so I reverted them back to defaults.

    I have enabled WP_DEBUG, but it shows no errors.
    Also, there are no errors displayed in Chrome’s dev console.

    There is a script at the bottom of the page that includes the image details (link, caption, description, etc) and there is a div with the ID ‘slb_viewer_wrap’, so it all seems to work, it’s only that when I click on an image it simply goes to the full image (not the attachment page, the image only).

    I have completely removed the plug-in, and re-installed and re-activated it. Unfortunately, same result.

    Plugin Author Archetyped

    (@archetyped)

    Hi, SLB was tested with the latest version of Laragon (4.0.15) and everything functioned properly.

    A WordPress site was created using Laragon’s “Quick App” functionality. Have you set up your WordPress site using a different method? If so, please provide details so that your setup can be replicated for testing.

    Please also provide the following details:

    • Laragon version
    • Any customized Laragon/PHP/Apache/etc. settings you are using
    • Browser you are using (OS and version)

    Otherwise, I would recommend testing SLB with a new WP site using Laragon’s “Quick App” functionality (ideally with the latest version of Laragon) to ensure that no other settings, etc. are causing the issue you’re experiencing. The results of testing SLB on a fresh site will help to narrow down the root cause.

    Testing with a different web browser (fully clearing the cache each time before loading the page) is also recommended to eliminate the browser as a factor.

    Thread Starter cambofrizz

    (@cambofrizz)

    Thank you for your reply. I followed your advice to set up a fresh site in Laragon. And with that your plug-in worked! But of course I wanted to know what caused the problem on the other site and I think I found it. When setting up a site in Laragon it uses the http:// protocol. If you have enabled SSL (under Menu > Apache) you can easily change to https:// and the site uses a certificate set up by Laragon. And then, your plug-in stops working.

    Just to be sure, I changed the initial site I worked with back to http:// and sure enough, then your plug-in worked.

    The question of course is why all other lightbox plug-ins I tested don’t have that problem. I’m keen to use yours, because of the simple templating you provide.

    By the way, I’m using version 4.0.16 of Laragon.

    Plugin Author Archetyped

    (@archetyped)

    Aha, this is why I asked for any custom settings you were using in my first reply.

    There appear to be issues with cURL (used by WordPress’ own wp_safe_remote_get() function) when Laragon is set to use SSL. Many users have reported this issue in Laragon’s forums, but it does not appear to have been resolved.

    I’m closing this as SLB works on properly-configured SSL sites and the issue is dependent on Laragon. I would recommend contacting Laragon’s developer to request that they resolve the existing issue.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.