Support » Plugin: Tailor Page Builder » is_customize_preview() doesn’t exist prior to 4.0.0

  • Resolved Simon.vdSteen

    (@simonvdsteen)


    Plugin uses is_customize_preview() to determin if it should run Tailor_Customizer::initialize(); but this results in a 500 error (PHP Fatal error: Call to undefined function is_customize_preview() in /wp-content/plugins/tailor/includes/class-customizer.php on line 157)of the full WordPress environment prior to 4.0.0.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Andrew Worsfold

    (@andrewworsfold)

    Hi Simon,

    Tailor doesn’t support versions of WordPress earlier than 4.3 and should actually prevent plugin activation in those instances. Were you actually able to run it on WordPress 4.0?

    Yeah, after adding the workaround yesterday I noticed the comment below.

    Tailor requires at least WordPress version 4.3. You are running version 3.9.2. Please upgrade and try again.

    I was checkin it on an legacy sandbox we use for compatibility purposes and didn’t notice the 4.3 requirement of your plugin.

    Other than that it seemed to activate trough the repo on 3.9.2 just fine, maybe you can add in an additional checkin mechanism to just be save ;).

    My earlier tests on 4.*.* versions of WordPress worked just fine, but as I said I wasn’t aware of the 4.3 requirement before running it on our “crap test” environment.

    Sorry for bothering you.

    Plugin Author Andrew Worsfold

    (@andrewworsfold)

    Thanks for the information 🙂

    I’ll check whether it does the same thing for me and, if necessary, put a fix in place.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘is_customize_preview() doesn’t exist prior to 4.0.0’ is closed to new replies.