• Resolved RashaMatt

    (@rashamatt)


    I used WPML to translate my English site (with one ticker) into additional languages. My English-text News Ticker was translated, and new Tickers were created for the translated languages.

    However, in the translated pages, the ticker shortcode (now referencing a translated ticker) seems to be ignored: no Ticker is output for the translated pages.

    Is WPML supported?

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author metaphorcreations

    (@metaphorcreations)

    Thanks for letting me know about this. It used to be supported, but I probably need to update some things to work with the latest updates of WPML. I’ll take a look at it sometime this week and see what I can do.

    Plugin Author metaphorcreations

    (@metaphorcreations)

    I ran some tests locally with WPML and it is still working as it should. It looks like your translated ticker may not have any ticks added to it? I checked the Spanish version https://bestcuttingdie.com/es/ticker/fomo-ticker/ and it seems to be empty (no ticks).

    Check that out and let me know if that’s the issue.

    Thread Starter RashaMatt

    (@rashamatt)

    The WPML-translated tickers look correct on the backend (not empty).

    https://snipboard.io/owhfBd.jpg

    • This reply was modified 11 months ago by RashaMatt.
    Plugin Author metaphorcreations

    (@metaphorcreations)

    Check out your Ticker Mode settings in your translated tickers and ensure they are set exactly like the main ticker. Save/Update the translated ticker (even if you don’t have any changes). Based on what I’m seeing in the rendered HTML it looks like the post meta for the Mode is empty.

    Let me know if that resolves the issue.

    Thread Starter RashaMatt

    (@rashamatt)

    Looks like the Ticker post meta didn’t get copied from the original to the translated ones… Would this be due to a WPML setting, or a bug?

    https://snipboard.io/xUa51O.jpg

    Plugin Author metaphorcreations

    (@metaphorcreations)

    All that data is just basic post custom metadata, which I’d assume WPML should be copying over. I found this thread that may help resolve the issue: https://wpml.org/forums/topic/copy-custom-field-content-to-translated-posts/#:~:text=Solution%3A%20Go%20to%20WPML%20%3E%20Settings,on%20the%20content%20and%20save.

    Plugin Author metaphorcreations

    (@metaphorcreations)

    I spent a little more time with this and realized I needed to update the wpml-config.xml file included in the plugin (It’s been a long time since I worked with the WPML). Please update to the latest version when you get a chance. Custom fields should now be copied when you translate. You may need to go into your WPML settings and just hit Update in order for these changes to take affect.

    You should be able to see (and modify) the individual translation settings for custom fields by viewing the Multilingual Content Setup metabox on your News Ticker’s edit page. You’ll need to select “Show system fields” in order to see them.

    Let me know if you still have any issues. Thanks!

    Thread Starter RashaMatt

    (@rashamatt)

    Thanks. After updating the plugin, it appears that _mtphr_dnt_mode (and quite a few other fields) still do not get copied to translated posts. Is this correct?

    screenshot

    Plugin Author metaphorcreations

    (@metaphorcreations)

    They should be copied now, though that seemed to be the case for me at first right after I updated the file. But, after I tinkered around in the admin they started copying as they should. I’m not sure what exactly did it, but I did go to WPML > Settings and switched to “WPML’s Advanced Translation Editor”, saved, and then switched back to “WPML’s Classic Translation Editor”. I’m not sure if saving those updates forced WMPL to re-read the config file, or if something else triggered my site to start reading the updated file correctly.

    So, you can give that a try. Or try creating a new tick and see if the copy settings are applied correctly. You could try disabling/enabling Ditty News Ticker and see if that trigger’s a re-read of the config file as well.

    Let me know if any of these things end up working for you.

    Thread Starter RashaMatt

    (@rashamatt)

    I changed all these to “Copy”, hit Update, and now they are all changed back to do-nothing :-/

    I have no idea what is going on.

    https://snipboard.io/Y72BGX.jpg

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Is WPML supported?’ is closed to new replies.