Support » Plugin: Wordfence Security - Firewall & Malware Scan » Is Wordfence compatible with PHP 7?

  • Resolved Martin1

    (@martin1)


    My host is offering me to move to PHP7. I was wondering if Wordfence is compatible with PHP 7?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author WFMattR

    (@wfmattr)

    Yes, we have no issues using PHP 7 and currently run it on some of our test servers.

    -Matt R

    Execllent, thanks for the quick response!

    I am seeing the following error in the compatibility checker for PHP7.1. Can you please confirm that WordFence supports PHP7.1

    FILE: /wp-content/plugins/wordfence/lib/wfConfig.php
    ————————————————————————————————————–
    FOUND 1 ERROR AFFECTING 1 LINE
    ————————————————————————————————————–
    534 | ERROR | Extension ‘mysql_’ is deprecated since PHP 5.5 and removed since PHP 7.0 – use mysqli instead.
    ————————————————————————————————————–

    Ambyomoron

    (@josiah-s-carberry)

    I run it on php 7.1 and have not noted any operational issues.
    You may note, however, that wordfence’s sibling service, gravityscan, flags php 7.1.0 as having a variety of security issues where php 7.0 and 7.1.5 do not. I don’t know precisely what those issues are.

    Hi.

    I understand WordFence is compatible with PHP 7.xx but, does it conflict with upgrading MySQL to MariaDB and PHP 5.6 to 7.xx? I asked because we just migrated our MySQL to MariaDB and the only website which has WordFence installed is throwing error, “Your PHP installation appears to be missing the MySQL extension which is required by WordPress.” We have done everything we can to make sure all PHP extensions are enabled for PHP 7 but, Still the problem is not solved. Any suggestions?

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Is Wordfence compatible with PHP 7?’ is closed to new replies.