WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Is upgrade from 1.5.1.2 with Fantastico possibble?

[Resolved] Is upgrade from 1.5.1.2 with Fantastico possibble?

  • bran8464

    @bran8464

    I have a blog still using WP 1.5.1.2 and fantastico is offering to upgrade it. Is this possible?

Viewing 9 replies - 1 through 9 (of 9 total)
  • whooami

    @whooami

    Member

    I wouldnt do it — but that doesnt mean its not possible.

    Back up your database first, if you try it.

    bran8464

    @bran8464

    Anyone else out there with a definitive view on this?

    bran8464

    @bran8464

    OK. It shouldn’t be difficult, but this will just disappear. It’s a simple query and the resaon for asking is that ALL my WordPress sites have been hacked in the last four weeks. All versions from 1.5.1.2 to 2.6.2 so it seems to me that WordPress is totally vulnerable.

    On the last occasion one of my domains was banned from the server. THIS IS GETTING SERIOUS GUYS. Sometimes WP is just part of a site. If the whole site gets banned because of WP then what do you do then?

    What I am doing is transferring hosting to wordpress.com but before I can do that I need import/export files. WP 1.5.1.2 does not have that facility. That’s why I want to upgrade so please, can Fantastico upgrade this to the latest version? Fantastico seems to think it can but I’m not so sure.

    bran8464

    @bran8464

    Very disappointing.

    bran8464

    @bran8464

    Hmmm . . . no one knows? Seems to me that I had either better not upgrade anything except to another blog system where there is a modicum of support.

    Thing is this is the usual response when I ask for help here . .

    I have another broken blog but I can’t ask here it seems.

    Moderator Jan Dembowski

    @jdembowski

    Brute Squad and Volunteer Moderator

    All versions from 1.5.1.2 to 2.6.2 so it seems to me that WordPress is totally vulnerable.

    Welcome to the reality of software. The security aspect is “they find them, they fix them” and 2.6.5 is the latest version which addresses a security fix.

    That’s just the way it is and no software is immune from bugs or security issues if a large group of people is using it and it is on the Internet.

    I don’t know if I agree that WordPress is the Windows software of blog systems but it would be hard for me to refute that.

    Hmmm . . . no one knows? Seems to me that I had either better not upgrade anything except to another blog system where there is a modicum of support.

    That would probably be best. This is a volunteer support site and 1.5.1.2 is years old. I don’t think that people are not supporting you as much as the reaction “Wow, he really is out of date”. The next version up 1.5.1.3 has time stamps around 7/2005.

    Not upgrading and maintaining your software is what got you into this mess and any system that you go to is going to need periodic maintenance.

    I wouldnt do it — but that doesnt mean its not possible.

    Back up your database first, if you try it.

    You’ve already gotten advice: did you back up your blog and try it?

    http://codex.wordpress.org/Backing_Up_Your_Database

    http://codex.wordpress.org/WordPress_Backups

    http://codex.wordpress.org/Upgrading_WordPress_Extended

    Good luck.

    bran8464

    @bran8464

    That would probably be best. This is a volunteer support site and 1.5.1.2 is years old. I don’t think that people are not supporting you as much as the reaction “Wow, he really is out of date”. The next version up 1.5.1.3 has time stamps around 7/2005.

    Not upgrading and maintaining your software is what got you into this mess and any system that you go to is going to need periodic maintenance.

    Well thank you for a reply. The 1.5.1.2 blog is the only one out of half a dozen that is out of date and that is because it is a modified blog and it has always been fine AND still is. It is all the later blogs that have been attacked. Upgrading it will be tedious unless fantastico can really do it.

    I only want to upgrade it so I can import it to wordpress.com

    I am reluctant to try the fantastico option because backing up etc seems to present problems and there is a risk I could lose the lot. My instinct tells me that 1.5.2.1 may have a different sql data structure so it could not be upgraded. However my fantastico is telling me it can be. I would just like some expert advice, that’s all.

    I would just like some expert advice, that’s all.

    and youve gotten some.

    Yes, not quite expert. I tried but that just screwed it up. The definitive answer that I was looking for was NO, Fantastico cannot upgrade 1.5.1.2, so if anyone else has that problem don’t do it. Do it the hard way.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Resolved] Is upgrade from 1.5.1.2 with Fantastico possibble?’ is closed to new replies.
Skip to toolbar