Support » Plugin: Google Analytics for WordPress by MonsterInsights » Is this compatible with Multisite?

Viewing 3 replies - 1 through 3 (of 3 total)
  • PLEASE! PLEASE! PLEASE! PLEASE! PLEASE! PLEASE! PLEASE!
    i have to resort to using 2 separate plugins cause i don’t want give up on your features but apparently i’m doing something in unsupported.

    thanks for all your hard work on the awesome plugin btw!

    Just fixed this locally for my multi-site install.

    In admin/yst_plugin_tools.php, on line 16:

    var $accesslvl = 'edit_users';

    Which means a users has to have that capability to see the plugin options page. On a single site install, this is fine, since Administrators have that capability. But in Multisite, only Super (Network) Admins have it. ( see the Roles and Capabilities page )

    I changed the line to this:

    var $accesslvl = 'edit_theme_options';

    … and everything seems to be working so far, even for regular (non-Super) Admins, since they have this capability by default in both single- and multisite.

    that’s pretty cool thanks for sharing! still looking to put my own tracking code in addition to theirs though.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Is this compatible with Multisite?’ is closed to new replies.