WordPress.org

Support

Support » Plugins and Hacks » Is there Support for Authenticate Before Update?

Is there Support for Authenticate Before Update?

  • Hi,
    Nice Plugin you’ve written.
    What I wanted to know is whether there is a capability to authenticate a user before getting an update. When the user tries to update the plugin, he is required to supply some kind of username/password and when the user inserts those, from our site based on the username we can check if the user has the ability to update. If not we can send a message saying that they don’t have the capability to do so and a message is shown to them on their site.
    Thanks

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author topquarky
    Member

    @topquarky

    Hi ppg,

    Authentication is not in there yet, but it’s something I definitely want for my own site as well. I just need to find a generic way to be able to pass that info along. Keep an eye out for updates. I suspect I’ll be figuring that out in the next week or so.

    Cheers
    Top Quark

    jquindlen
    Member

    @jquindlen

    I saw on another thread that you had figured this out. Any help with it would be greatly appreciated. Thanks for the plugin and the hard work.

    Plugin Author topquarky
    Member

    @topquarky

    Hi @jquindlen,

    Yes, the latest version has support for authentication, though it’s not built into the plugin itself. It’s something that you would have to add yourself using a third-plugin and available filters.

    I’ve just posted an article on my site about one way to do this. See http://topquark.com/blog/2011/07/08/adding-authentication-to-self-hosted-plugins/.

    I don’t actually have plans to add Authentication to the plugin itself as I think that developers are all going to have different ideas on how they want to do authentication – maybe charging for plugins, maybe using a third-party membership plugin (as I do on my own site, topquark.com).

    Cheers
    TopQuarky

    jquindlen
    Member

    @jquindlen

    @topquarky

    You’re the man! Thanks for putting together a top notch plugin and supporting it to boot! 5 stars!

    Plugin Author topquarky
    Member

    @topquarky

    Thanks @jquindlen!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Is there Support for Authenticate Before Update?’ is closed to new replies.