Support » Plugin: Simple Mathjax » ‘Load MathJax on admin pages?’ does not work on mathjax 3.x

  • Resolved powercliff

    (@powercliff)


    Update:
    I just found that option ‘Load MathJax on admin pages?’ does not work on mathjax 3.x: whether or not I enable this option, the mathjax 3.x does not load on admin pages.
    My personal issue has been solved, and I changed the title of this topic. Now the topic turned to a tiny bug report.
    ————————————-

    Hi,

    Thank you for developing the plugin!
    I find that only Mathjax-2.x typesets equations in Gutenberg Editor, while mathjax 3.x will not:
    if i write some Tex based equations in Gutenberg Editor, and after refreshing the page, the Tex texts will turn to rendered mathjax equations, and the data stored in mysql also changes to html based content.
    It is extremely terrible for wordpress database storing, since it is very easy to store raw mathjax html in mysql database instead of original Tex texts.

    The mathjax 3.x does not typesetting Tex in Gutenberg Editor, which makes the database very clean: only the original Tex texts will be stored.
    Is there methods to stop mathjax 2.x typesetting equations in Gutenberg Editor, like mathjax 3.x?
    I still prefer to use Mathjax 2.x if I have a chance to choose. But if it is impossible to do this, then I will consider migrating to mathjax 3.x.Thank you!

    • This topic was modified 4 months, 2 weeks ago by powercliff.
    • This topic was modified 4 months, 2 weeks ago by powercliff.
    • This topic was modified 4 months, 2 weeks ago by powercliff.
    • This topic was modified 4 months, 2 weeks ago by powercliff.
Viewing 1 replies (of 1 total)
  • Plugin Author pkra

    (@pkra)

    It seems you’ve marked this issue as resolved. Just in case: there’s an option in the plugin’s settings for rendering in the admin areas; it should be off by default.

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.