Support » Plugin: Elementor Page Builder » Is there anyway to get Elementor to use the same language as my admin Dashboard

  • Resolved caeruleus

    (@caeruleus)


    I am working in a multisite environment using Polylang. My user profile is set up in English and almost everything in the admin actually works in my chosen language. For some reason though, Elementor only seems to display in Chinese.

    Is there any way to force the plugin to use my user selected language rather than whatever language it has decided to utilise?

Viewing 15 replies - 1 through 15 (of 18 total)
  • hi
    try unistalling and réinstalling elementor clear cache after uninstalling

    Just tried that again to make sure.. Still the same problem.

    To clarify a bit, only the editor window displays in Chinese. All the dashboard admin preferences are displaying in English as intended.

    Caereolous
    Try so going see if elementor nee un update !

    Updated to latest version. Have also tried rolling back to two previous version of the plugin with no luck.

    Also just tried creating a fresh admin user with English language preference and experiencing the same issue.

    yes, get to zip in your language a fresh one !!!

    I hope you re- dowload from your language, uninstall clear cache, and make fresh reinstall

    Caeruleus
    Try to check and Set admin language as editing language.
    in User Profile Polylang options

    Fantastic! Instead of downloading through the WordPress plugins interface, I downloaded directly from the WordPress site as a ZIP file. It seems to be working so far. Fingers crossed it continues that way.

    @alvarez560 Thanks for your prompt assistance!

    Great !!!!!
    you’re welcome now may a fantastic website Caeruleus !!!!!!!!

    Sorry to be back so soon.. It displayed in English only for a couple of times and then reverted back to Chinese.

    I can’t see any option in my user profile to “Set admin language as editing language”, though it sounds promising.

    because some rest keept into the folder.
    try to make the must clean installation

    uninstall – clear cache – refresh page – reinstall again

    that editor window ho’s displaying in Chinese is the conflit !!!!
    so is elementor or polylang..

    focus on it to uninstall and reinstall

    Redone that.. It obviously worked in English until the Chinese language pack was installed, but then started reverting back to Chinese once the translations were available. Deleting the language pack is not really a viable solution as we have non-English speakers on the team that still need to be able to access the interface in Chinese.

    yano23

    (@yano23)

    I need this badly too. Elementor should have an option for selecting the language (it doesn’t affect front-end) or at least should respect the language selected by the user, not the website’s. I have Elementor Pro and it keeps translating, it’s frustrating.

    I like elementor but I totally hate them making people that speak english to use it in the WordPress native language and if you want to switch you have to add add-ons, so what I did is login via FTP/SSH to the public_html/wp-content/languages/plugins and set the permission to 444 for the translation file to elementor and bingo no more translation to the plugin EVER!!!!!

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘Is there anyway to get Elementor to use the same language as my admin Dashboard’ is closed to new replies.