Support » Plugin: AUS Telegram Channel » is there any issue … not working, please help to solve it

  • Resolved pavelpluz

    (@pavelpluz)


    is it working ? because I configured everything as explained, created bot …got token and put it in settings.. but nothing happened…also waited 1 hour because I put there once hourly… in same time after posted about 15 posts but did not get anything in telegram from bot that I created …used other mobile to subscribe and clicked /start …. nothing happened even after 24 hours.. so dear Anvar please advice… thank you

    https://wordpress.org/plugins/aus-telegram-channel/

Viewing 15 replies - 1 through 15 (of 17 total)
  • ???? hello

    Plugin Author Anvar Ulugov

    (@ulugov)

    Hello Pavel. Sorry for late answer.
    This plugin sends wordpress posts to provided telegram channel.
    1. First you have to create a public channel. 2. And than you have to create a bot.
    3. Than you have to add your bot as administrator to your channel.
    4. And enter the channel username (e.x. @ulugovuz) and your admin bot token that given by @botfather.

    By the way, if you want to check if plugin works I advice you to use the plugin ‘Advanced cron manager’. After installing it you can find a menu in Tools section. On that page find the ‘aus_telegram_channel…’ Schedule and run it. The post will be seen on your telegram channel.

    I hope, the answer was clear. If you have any questions, please write. I’ll do my best to support you.
    Thank you for trying my plugin.
    Regards.

    Plugin Author Anvar Ulugov

    (@ulugov)

    I added a post with screen shots. Please check it. I hope it will help you:

    AUS Telegram Channel configuration example

    hello thank you for clear explanation.. I tried and did exactly step by step your recommended procedure… but published posts not sending to telegram. I even did same like your screen shots… also tried to use both: bot name and channel name in (Insert @channelusername)… also installed that plugin u mentioned “Advanced Cron Manager”..I can see there hook “aus_telegram_bot_schedule” up and running showing Next execution in time…so I even tried to run execute manually.. but nothing happened in telegram channel… I dont understand what I am doing wrong..or any issue with plugin.. so dear friend A.Ulugov kindly advice

    thanks

    Best,
    Pavel

    1. is there any way to create video instruction?
    2. from where your plugin grabs(gets) posts? from rss or while I click publish.. and how many posts it will send to telegram..? what if I publish every hour more than 20 posts..?
    I want it to work… I liked your plugin because as I think it has no ads, and other headaches. easy to use, but unfortunately I could not solve yet my issue why its not working.. so I will wait for your reply.thanks

    Plugin Author Anvar Ulugov

    (@ulugov)

    Hello Pavel.
    1. I will try to create a screencast soon.
    2. This plugin does not grab the posts, it just querys the posts by date (ASC) and takes the oldest one. And sends it to your telegram channel. This procedure will be repeated according the recurrence you chosen on plugin options. E.g. if you choose period ‘Hourly’, the plugin takes the oldest post by date and sends it to telegram channel. If you set a date on plugin options page e.g. 2015.05.01 the plugin takes the oldest one that published after 2015.05.01 and sends it to telegram channel.
    If you publish more than 20 posts a day, the plugin does not care it. It just keeps sending posts one by one.

    ok thank you,,will wait your reply.

    Plugin Author Anvar Ulugov

    (@ulugov)

    Hello Pavel.
    I created a screencast. You can watch it on plugin installation section.
    https://wordpress.org/plugins/aus-telegram-channel/installation/

    Hello Anvar,,thank you for video explanation,,,, its same procedure you already explained to me … what I did now is recreated everything one bye one as you showed on video..following your instruction ,,, after i click execute on cron… nothing happens on my channel …. very strange….. after I thought maybe some plugins conflict I tried to use your plugin to my another website ,,,but same situation…. Is it possible that something blocking it ? or hosting? I use ipage hosting.. you are programmer and I think you know what might effect it not to work…

    Plugin Author Anvar Ulugov

    (@ulugov)

    Paste the following url to you browser address change the token and channelusername parameters and try to open. The result message will be displayed as json array. If everything works the message must be sent to your channel.

    https://api.telegram.org/bot{bot-token}/sendMessage?chat_id=@channelusername&text=test message

    Plugin Author Anvar Ulugov

    (@ulugov)

    if everything works, paste the save code in a php file and upload it to your hosting. And browse it.
    E.g.

    <?php file_get_contents('https://api.telegram.org/bot{bot-token}/sendMessage?chat_id=@channelusername&text=test message'); ?>

    hello dear Anvar… yes I tested it pasted url to browser and test message appeared on my channel… after I uploaded php file to my hosting and browsed it ,,,but nothing happened ….

    I know your plugin is awesome but I do not know why its not working from my side..is there any idea to do?

    Plugin Author Anvar Ulugov

    (@ulugov)

    Hello pavelpluz.
    I think your hosting provider made some limits.
    please, test with the following code below:

    <?php
    $result = file_get_contents('https://api.telegram.org/bot{bot-token}/sendMessage?chat_id=@channelusername&text=test message');
    print_r($result);
     ?>

    Maybe some thing will be visible.
    And I advice you to check your sites access and error logs after testing this code.

    hello, I did browse but nothing appeared so after I found from server Check Error logs this error:
    I changed my website name for security purpose. see error and let me know what I should do.. thank you Anvar

    20151220T052955: mysite.net/testphp1.php
    PHP Warning: file_get_contents(): https:// wrapper is disabled in the server configuration by allow_url_fopen=0 in /hermes/bosnaweb02a/b2273/ipg.mysite/mysite1/testphp1.php on line 2
    PHP Warning: file_get_contents(https://…@mytest111&text=test message): failed to open stream: no suitable wrapper could be found in /hermes/bosnaweb02a/b2283/ipg.mysitecom/mysite1/testphp1.php on line 2

    Plugin Author Anvar Ulugov

    (@ulugov)

    Hello. I thing the answer is here:

    PHP Warning: file_get_contents(): https:// wrapper is disabled in the server configuration by allow_url_fopen=0

    You must contact with your hosting provider support.
    Regards.

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘is there any issue … not working, please help to solve it’ is closed to new replies.