Support » Plugin: Bitcoin and Altcoin Wallets » Is there a way to change the first selected coin via [wallets_deposit]?

  • Surrealer

    (@surrealer)



    Hello,
    is there a way to change the first selected coin via [wallets_deposit]?
    I want to display it on different pages with different preselcted coins.
    Is there something like [wallets_deposit select=”bitcoin”]?

    Thank you and kind regards
    Arne

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author dashed-slug.net

    (@dashedslug)

    Hello Arne,

    This is not possible because the selected coin does not correspond 1-to-1 with any particular shortcode or UI. The selected coin is a setting that applies throughout the entire page and all its UIs.

    What you can do however, is to set the currently selected coin with JavaScript. For example, to set the selected coin to be Litecoin (assuming Litecoin is enabled on your site) you would call:

    wp.wallets.viewModels.wallets.selectedCoin('LTC')

    Unfortunately if you attach this to the document ready event it might not work, as the coin data might not have been loaded yet. I will add some kind of callback mechanism in the next release so that things like this will be possible. Something like a “wallets ready” event that you can attach JavaScript to.

    I will let you know here once this is done.

    kind regards

    Surrealer

    (@surrealer)

    Hello Alex,
    that sounds great! then I will wait until the next release to add it to my project.

    Thank you very much for your fast and helpful support – as always!

    You will have ma as new premium member during this week

    Plugin Author dashed-slug.net

    (@dashedslug)

    Hello Arne,

    Thank you for your feedback.

    Your request has now been addressed in 3.5.1. Please see the relevant blog post and the documentation.

    The documentation includes a complete example of how you would go about to set the default currency.

    kind regards

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.