WordPress.org

Forums

Is there a post size limit? (37 posts)

  1. ditchtech
    Member
    Posted 6 years ago #

    Hi, when i create a post, and than try to update with with
    a link/image or any html code, I end up getting an error on trying to publish/preview. Is there a size limit to the database?

  2. t31os
    Member
    Posted 6 years ago #

    The database table/row uses "longtext" (at least in 2.7.1 on my install), which supports upto at least a few trillion characters...

    Not sure if there are any WP functions that check the post length, but it's certainly not a restriction with the database table..

  3. ditchtech
    Member
    Posted 6 years ago #

    Thanks tr1os.
    Character count is about 600. Further the page not found error,
    only appears when i try a link/image insert towards end of my post.
    Are there chances of escape sequence creeping in and spoiling the update?
    anyone else got the same problem?

  4. t31os
    Member
    Posted 6 years ago #

    You're welcome fitchtech ... ;) ....

    Can you link or insert images ok in new posts?

  5. theperryfamily
    Member
    Posted 6 years ago #

    I'm having this same problem

    I create rather lengthy tutorials and then go back into the tutorials and add screenshots etc to demonstrate each step

    Whenever I get near the end, and add an image, then try to save as draft or publish, the page refreshes (as it is saving), but after the refresh the entire post text area is blank...my entire post and pictures are all gone...

    this is very frustrating...

    I can't find any solutions to this issue, however I don't have this issue using b2revolution, so rather than struggle with WordPress, I've just been using b2revolution instead

    but would hope that the WordPress folks would fix this to allow me and others to use their product

  6. shellius
    Member
    Posted 6 years ago #

    Hello,

    What theperryfamily describes -- this is also happening to me! I have the latest version of WP, 2.8.1. On a long post, when saving, the post disappears entirely. I can't make it stay and I can't get it to post. I have checked all over for answers to this and no one seems to know why this would happen! (This has never happened to me before, only with this version of WP.) I guess I will try to split the post up into two posts, but that will really mess things up for me. I hope this problem disappears with the next version, but if not, is there any fix for it now?

    P.S. this is not an image problem for me, simply text.

  7. SeanTerrill
    Member
    Posted 6 years ago #

    I'm having the same issue. I can't be sure it's tied to 2.8.1 because I hadn't tried a post this long under previous versions.

  8. t413
    Member
    Posted 6 years ago #

    I have the same exact issue with a huge glossary post, but I figured out a workaround:

    Using phpmyadmin to edit the post_content field under the wp_posts entry for your post you can paste in your html and it updates the blog entry without using wordpress. This works, which says three things: the issue is not a mysql, php, or server configuration problem– it's wordpress.

    It's mostly simple if you have phpmyadmin, know how to use it, and don't ever need to conveniently update your post.

  9. intelligentinfo
    Member
    Posted 6 years ago #

    I have the same issue with Version 2.8. When I want to edit a long page (more than 3000 words), the textbox for the content will not appear.

    Thank you for the tip with phpmyadmin. It works, but it also means that you have to edit the page with phpmyadmin. In this particular case editing is envisaged (it is not a blog post, but a page). This, of course, is only possible if you, as an editor, have access to the database with phpmyadmin. In my case that is no problem, but in an environment, where editors should access the blog only through wordpress, this will be a problem.

    Would be nice, if somebody could sort this out.

  10. ragoczy
    Member
    Posted 5 years ago #

    I'm having exactly the same difficulty with the length of page. Has there been any solution to this yet?

  11. Mark / t31os
    Moderator
    Posted 5 years ago #

    Using phpmyadmin to edit the post_content field under the wp_posts entry for your post you can paste in your html and it updates the blog entry without using wordpress. This works, which says three things: the issue is not a mysql, php, or server configuration problem– it's wordpress.

    Actually this only suggests that the problem isn't with mysql, it doesn't tell us it's not a problem with either of the others..

    I'll make some long posts on my local install tomorrow and see if i can replicate the problem...

    In the mean time please ensure you've all done the usual process for isolating problems (sure you've read these kind of replies before)..

    Disable plugins, test page.
    Switch to default theme, test page.
    Switch to default permalinks (worth a shot), test page.
    Try another browser.
    Try another PC.

    Doesn't matter how unlikely any of the above are, they only take 5 minutes to test..

  12. dbasulto
    Member
    Posted 5 years ago #

    Nice to see that i´m not the only one with the problem :)

    I just noticed that on WP 2.8.4 a post was published (before the "read more" cut), and I can see it on the front page. But going to the single view of the post... no content was shown. As it had a lot of text and some images, I decided to re post it by blocks to see at which point it failed.

    Then when I was almost done I noticed it failed. Then if I removed one single paragraph (plain text, nothing fancy) the post appears complete. If I added any paragraph..it failed. This happens at 55,000 characters with spaces (had to use word to check it).

    Anyone knows how to open a ticket for this?

  13. Schleicher
    Member
    Posted 5 years ago #

    Bump! I'm having the same problem, and it just started recently.

  14. Mark / t31os
    Moderator
    Posted 5 years ago #

    I never did get to testing this (soz), i'll go give this a go now..

    55000 is the target then... i'll see what happens.

  15. Mark / t31os
    Moderator
    Posted 5 years ago #

    Done a few post tests just to see if i'd hit a wall with high word counts.. Here's the results.

    Single post: (no more / no pages)

    Word count: 80010 - success
    Word count: 160021 - success

    Single post: with <!--more--> (no pages)

    Word count (before "more"): 81886
    Word count (after "more"): 78136
    Total: 160022 - success

    Single post: with <!--nextpage--> (no more)

    Word count: 10000 per page (14 pages total)
    Total: 140000 - success

    I each previewed post as i made the changes, then saved, and checked the page again. Each time the page loaded and showed the content as expected.

  16. UBenzer
    Member
    Posted 5 years ago #

    I have the same problem. :(

    It is about wpautop. When I disable WordPress' auto formatting then the content is shown again. (I use text-control plugin for it)

  17. UBenzer
    Member
    Posted 5 years ago #

  18. kimijye
    Member
    Posted 5 years ago #

    Please see my post at http://wordpress.org/support/topic/298853?replies=18#post-1204777 . I detail my fixes for this and other issues, everything is now working fine.

  19. chartinael
    Member
    Posted 5 years ago #

    Same here ... also, short code seems to be the issue ... As if there is a limit to how much short code you can insert without being specified anywherhe.

    It is bothersome. The php.ini is only an option where one has access to it. i don't so I need a fix that does not involve tweaking php.ini

  20. Dark Severance
    Member
    Posted 5 years ago #

    This is definitely an issue that I'm having. This was with the default, freshly installed Word Press. I didn't start using another theme until after I got tired trying to figure out what was not allowing me to post, just giving me a blank page.

    It doesn't seem to be a set amount of words either. I tried posting 15,061 Words (81,789 Characters) and it didn't work. But if I posted 12,042 Words it would work as long as I used <!--nextpage-->. I did another post with 16,213 words and it worked with <!--nextpage-->.

    I'd prefer that I didn't have to use nextpage. It does seem that if I'm using pictures then that limits how many words I can post even more.

  21. cabaa99
    Member
    Posted 5 years ago #

    In my case, large posts, when displayed, where blank (no text). I had some shortcodes, not a lot.

    I read the explanation at http://www.undermyhat.org/blog/2009/07/sudden-empty-blank-page-for-large-posts-with-wordpress/ that UBenzer indicates... however, for me the solution was to COMMENT OUT the preg_rep line in formatting.php, rather than uncommenting. I am using WP 2.8.4.

  22. chartinael
    Member
    Posted 5 years ago #

    when I add an empty post with 15 caption shortcodes, the page comes up. (ie upload via media manager 1 image and copy inserted code one by one.)

    when I add the image a 16th time, post blanks out on me.

    One caption image with a 10.000 character blind text works. With 20.000 it blanks out. One caption image with 17 1000 character paragraphs is fine ... add another it blanks out. Add another caption image to the 17 1000 character paragraphs, it blanks out.

    This is not nice at all.

  23. chartinael
    Member
    Posted 5 years ago #

    Hey, Cabaa ... thanks, that works for me 2. Let me know if you notice any weird behavior.

  24. rstritmatter
    Member
    Posted 5 years ago #

    Same problem here. Extremely irritating. Is there some fix for this?

    Length of post is the only variable that seems to make a difference for me. Short is ok. Anything over several thousand words, which is most of the articles I am posting, and I get hung up trying to save, edit, or preview.

  25. jcv
    Member
    Posted 5 years ago #

    I experiment also this bug. Seems to be quite generalised.

    Shouldn't we open a bug? How could one open a bug?

    Shouldn't this be sticked?

  26. Quick fix: Add this to your wp-config.php (at the top):

    ini_set('pcre.recursion_limit',20000000);
    ini_set('pcre.backtrack_limit',10000000);

    Might work. Might not.

    This is an extremely rare problem, so no, I don't think it should be stickied. Not much WP can do about it anyway, it's a PHP setting thing.

  27. MaxiesGal
    Member
    Posted 5 years ago #

    Thanks Otto, your suggestion worked. I can now insert text AND images, hit 'publish' and no more blank pages !

    I used <!--nextpage--> to break up pages, which solved my 'excess text' issue. I placed your code in my config and I can now insert images freely.

    This has been keeping me up at night for two weeks so I thank you most kindly for the 'fix'

    Regards,
    Cat

  28. aiadvisors
    Member
    Posted 5 years ago #

    Otto42 wins the prize. He's so modest: "Might work. Might not."

    Yeah, well it works!

    Thanks!

  29. Lee
    Inactive
    Posted 5 years ago #

    Otto42, thank you so much.

    My post just disappeared after I had updated it and only the comments showed, I wondered what was going on; I thought I'd been hacked or had incorrectly edited my page's HTML. Took a few minutes to twig that the issue was related to a post size limit; and that was only because I noticed the preview page showed the post but the direct URL of the page didn't show it.

    Perhaps WordPress could include an editable Post Size Limit setting in the Dashboard.

    Again, thank you for providing a solution.

  30. diondeville: WordPress has no inherent post size limit. The solution I gave above changes a couple settings in your PHP installation to up the limit for regular expression parsing.

    Under normal circumstances, the setting should not be needed. In some special cases, on special setups, the shortcode parsing routines can hit a default limit in the PHP installation. That code above ups the limit, a lot. Downside: It could make your blog quite slow sometimes. But not usually.

Topic Closed

This topic has been closed to new replies.

About this Topic