Support » Plugin: GEO my WordPress » Is there a maximum number of profiles to use GEO my WP?

  • Resolved michaelgimm

    (@michaelgimm)


    Somehow I can’t add any more vendors to this page. It uses GEO my WP together with BuddyPress.

    The author of my theme (REHUB) says it might be related to Google API quote:

    “I think you need to create a new unlimited Map API key or add the sites to current. Free API key allows only one query to Google server per day.”

    And:

    “Your error from gmw_geocoder() function in GeoMyWp plugin – http://prntscr.com/l3varj ( https://console.developers.google.com/apis/credentials?project=_ )

    Because of this error, GMW cannot save a vendor address in the database.”

    Do you have any input to this? Should I pay for Google API?

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • I added billing account in google like you suggested in your guide, but I still can’t make it work. Any ideas?

    Plugin Author Eyal Fitoussi

    (@ninjew)

    Hi Michael,

    This might be the same issue described here. Looks like I need to add an additional setting field for a server side API key.

    Until I have a new version with the setting field for the server-side key ready, you can try solving this issue by creating a server-side Google Maps API and enter it directly into the plugin’s core file.

    Creating a server-side API key is almost the same as creating a client-side key ( which is the one you have already generated ).

    The difference is in the API key type. For client-side ( browser key ) API key you need to select “HTTPS referrers” in the API type ( see image ). And for server-side key, you need to check the “IP Addresses” type ( see image ).

    once you have the server side key ready, you will need to add it directly into the plugin’s file. To do so, open the file geo-my-wp/includes/gmw-geocoding-providers.php and in line 38 which should be:

    'key' => gmw_get_option( 'api_providers', 'google_maps_server_api_key', '' ),

    replace:

    gmw_get_option( 'api_providers', 'google_maps_server_api_key', '' )

    with your server-side API key.

    So line 38 should then be:

    'key' => 'your server-side api key goes here',

    Save the file and test it to see if it works.

    let me know how it goes.

    I tried but its not working. Created new API with IP address from my server/host (shared server/hosting), and added it in plugin on my staging environment to test: http://staging1.weensu.dk

    See this: https://www.dropbox.com/s/35ewycvgp5otec0/image002.png?dl=0
    and this: https://www.dropbox.com/s/jyrmsdnty1p7w8p/image001.png?dl=0

    If I add vendor on map from vendor dashboard (the way I am used to), the vendor is not appearing.

    Plugin Author Eyal Fitoussi

    (@ninjew)

    Michael,

    In the same geocoding providers PHP file replace lines 57 – 60 which should be:

    
    'url_data' => http_build_query(
        apply_filters( 'gmw_google_maps_api_geocoder_args', $this->params ),
        '', '&'
    ),
    

    with:

    
    'url_data' => http_build_query(
        apply_filters( 'gmw_google_maps_api_geocoder_args', $this->params )
    ),
    

    Save the file and try again.

    Let me know if this works.

    No its not working unfortunately. See this video also: https://www.useloom.com/share/8d9257020b1b4f588c8d72ee41a7a41a

    Plugin Author Eyal Fitoussi

    (@ninjew)

    Hi @aberdov,

    I am not sure why it isn’t working for you. So far it has been working for all users.

    I have just uploaded a beta of the new version which includes the new setting for the server key and some improvements to the geocoder class.

    You can download it from here.

    Do you think you can give it a try on your client’s site?

    Hi, @ninjew

    Yes, now the address synchronization works. Thank you very much.

    Moderator Jan Dembowski

    (@jdembowski)

    Forum Moderator and Brute Squad

    NUTS.

    @ninjew I have flagged your account for moderation watch.

    https://wordpress.org/support/guidelines/#being-mod-watched-or-banned

    I have also deleted your offer to login to your user’s site. I’m am 100% sure you mean well but please never ask for credentials on these forums.

    https://wordpress.org/support/guidelines/#the-bad-stuff

    Now for the why: The internet is a wonderful place full of very nice people and a few very bad ones. I’m sure everyone here is very nice however, by giving some ones keys to your house you are trusting they wont steal anything. Likewise the person who takes the keys is now responsible for the house FOREVER.

    If something was to go wrong, then you the author may well legally become liable for damages, which they would not normally have been as their software is provided without warranty.

    Please be aware that repeatedly asking for credentials will result in us asking you to repeatedly stop before escalating up to the plugins team.

    Plugin Author Eyal Fitoussi

    (@ninjew)

    @jan,

    Noted. Thanks for the information.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Is there a maximum number of profiles to use GEO my WP?’ is closed to new replies.