Support » Fixing WordPress » Is there a known Chrome bug with WP 4.3 on Mac?

  • Resolved sem101

    (@sem101)


    Admin menus get jarbled and sometimes disappear!

    Chrome 45.0.2454.85
    WordPress 4.3
    Fresh install. No plugins. Twentyfifteen.

    Here is a screencast:
    https://youtu.be/F8tz3SeRbDU

    Admin works fine in latest Safari, Firefox. Anyone else have this problem?

Viewing 15 replies - 16 through 30 (of 41 total)
  • Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Dave van Hoorn: I’ve been telling this to people all day, and they’re all saying it works for them.

    The bug itself was narrowed down to a specific change in Chrome which says “Enable Slimming Paint by default in Chromium and Blink”. Disabling this does the trick for me in Chrome 45, 46, and 47.

    https://code.google.com/p/chromium/issues/detail?id=509179#c17

    So, if there’s some other setting that affects this issue, I’d like to know about it.

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    Dave van Hoorn: Oh, I just noticed. You have both of those settings wrong. You have the “disable-slimming-paint” disabled, and the “enable-slimming-paint” enabled. The Enable and Disable things there are links. That’s an action to be taken, not telling you of the current state.

    The enabled flags will have a background color of white, while the disabled ones will have a background color of grey.

    This is what it should look like:
    https://cloudup.com/cddYghY8fBd

    I know. It’s weird. Blame Chrome.

    Damn! You’re right. And I feel pretty stupid now. Thanks for sticking with me though, it’s fixed.

    can confirm that the functions.php code works.
    if looking for easy way to restart chrome

    `chrome://restart

    Dave van Hoorn, thanks for the code, it worked for me. I think it is better to fix it via functions.php, because otherwise you would need to change the browser settings on every Chrome browser that is used for accessing the admin panel, which is unwanted extra work in bigger projects.

    Thanks @dave van Hoorn. Solved easily by adding the above code to functions.php.

    raffjones and Samuel Wood (Otto) thanks for the fixes! I was going crazy wondering what I had broken. 🙂

    Thanks Otto!

    Worked Great!!!!

    All well and good advising disable-slimming-paint”, and “enable-slimming-paint”, but to non-techie types, we have no ideas where to do this!

    I need a chrome wide fix for this, as it’s happening on all my client sites. Can anyone point me to where I can disable-slimming-paint”, and/or “enable-slimming-paint”?

    many thanks.
    Dumbo

    ———

    My bad!!! – I just found some instructions on another site. Please ignore me…as if you hadn’t already! – Doh!

    Samuel Wood (Otto) Thank you very much!!! This was driving me up the wall. Appreciate you!

    Samuel Wood (Otto), it worked for me.
    win7, chrome v45.0.2454.85
    thx.

    Hoping Google solves this quickly. Not really an option to add code to functions.php for several hundred WordPress sites.

    The fix provided by Otto, worked out for me @ WIN10, Chrome 45.0.2454.85

    To avoid having to update dozens of functions.php files I’ve packaged the fix into a Chrome Extension. It will apply the fix to any pages with /wp-admin/ in the URL.

    The extension can be installed from the Chrome Store:
    https://chrome.google.com/webstore/detail/wordpress-chrome-bug-fix/kfagnlhfdmaiflgmmppoceboadljmeoe

    Or you can download from Github and install as an Unpacked Extension:
    https://github.com/funkjedi/wp-chrome-bug-fix

    Fix worked for me – thanks, Otto!

Viewing 15 replies - 16 through 30 (of 41 total)
  • The topic ‘Is there a known Chrome bug with WP 4.3 on Mac?’ is closed to new replies.