Support » Fixing WordPress » Is there a known Chrome bug with WP 4.3 on Mac?

  • Resolved sem101

    (@sem101)


    Admin menus get jarbled and sometimes disappear!

    Chrome 45.0.2454.85
    WordPress 4.3
    Fresh install. No plugins. Twentyfifteen.

    Here is a screencast:
    https://youtu.be/F8tz3SeRbDU

    Admin works fine in latest Safari, Firefox. Anyone else have this problem?

Viewing 15 replies - 1 through 15 (of 41 total)
  • Video was very useful.

    I haven’t seen this and have used on Chrome on Mac…

    Are you perhaps using any Chrome apps/extensions? They can change things on the page etc.

    Are you running the same Chrome version as me?
    Yes, I’ve disabled all Chrome extensions.
    I’m going to try on another computer right now…

    Sorry I haven’t got a Mac with me, it was at a friends house – but we had no issues…

    Sorry I couldn’t help futher – but I am fairly sure this should be happening – a big chunk of the actual WP devs will use Macs…

    Same problem for me on WP 4.2 after upgrading to Chrome 45.0.2454.85.

    Moderator Jose Castaneda

    (@jcastaneda)

    THEME COFFEE MONKEY

    There is a core ticket for it:
    https://core.trac.wordpress.org/ticket/33199

    Please note that it is version 45+ of Chrome that is currently effected.

    Collapsing the menu and uncollapsing it again seems to fix the issue. Found this plugin which implements this as a temporary fix.

    https://github.com/raffjones/chrome-admin-menu-fix

    Thanks Jose and funkjedi, I’ll try the hotfix.

    Note, it still exists in: Version 47.0.2499.0 canary (64-bit)

    I’ve just updated the plugin to target all versions of Chrome temporarily. It was just targeting version 45.x but it seems that versions > 45 are still broken. https://github.com/raffjones/chrome-admin-menu-fix

    Chrome 45 has a rendering bug.

    – Go to chrome://flags/#disable-slimming-paint
    – Enable the “Disable slimming paint” option.
    – Ensure that the “Enable slimming paint” option below it is not turned on.
    – Relaunch Chrome.

    Hi Samuel, unfortunately that didn’t do it for me. @raffjones and your followup in the core ticket did. Posting it here for reference:

    Paste this in your functions.php

    add_action('admin_enqueue_scripts', 'chrome_fix');
    function chrome_fix() {
    	if ( strpos( $_SERVER['HTTP_USER_AGENT'], 'Chrome' ) !== false )
    		wp_add_inline_style( 'wp-admin', '#adminmenu { transform: translateZ(0); }' );
    }

    Dave van Hoorn: That has been confirmed to work. Just remember that “Relaunch” is special in Chrome. Simply closing the window and opening it again does not relaunch Chrome completely.

    When you change the setting, there should be a Relaunch button at the bottom of the screen. Until Chrome is completely relaunched, the setting change won’t take effect.

    I’m sorry, but changing the Chrome flags did not solve the issue. I tried it on another device (Macbook Pro – Chrome 45.0.2454.85 (64-bit) – no extensions) and relaunched Chrome by the “Relaunch Now” button in the bottom left corner of the window. The menu’s still messy.

    I confirm the same problem reported by @sem101

    WordPress 4.3 – Mac OS X 10.10.5 – with Chrome 45.0.2454.85

    Thanks @dave van Hoorn, the code that you have shared it works fine and resolve all the problems in the backend.
    Thanks again

    Dave van Hoorn: Double check that you did not also enable the “enable-slimming-paint” option. If you enable both disable-slimming-paint and enable-slimming-paint, then the problem will persist. I know, it’s weird that they have two flags there.

    This is a confirmed fix. Using code like the above will work, but only on one site. Fixing Chrome will make all sites render properly for you.

    Copied from my Chrome flags:

    Disable slimming paint. Mac, Windows, Linux, Chrome OS, Android
    Do not use the slimming paint display lists for drawing. Note the enable-slimming-paint flag takes precedence over this flag if both are present. #disable-slimming-paint
    Enable
    Enable slimming paint. Mac, Windows, Linux, Chrome OS, Android
    Use the slimming paint display lists for all drawing. Takes precedence over the disable-slimming-paint flag if both are present. #enable-slimming-paint
    Disable

    Where was this fix confirmed?

Viewing 15 replies - 1 through 15 (of 41 total)
  • The topic ‘Is there a known Chrome bug with WP 4.3 on Mac?’ is closed to new replies.