Support » Plugin: WordPress Gallery Plugin - NextGEN Gallery » Is Nextgen PHP7 Compatible?

  • I’m using the PHP Compatibility Checker to see if a client’s site has any compatibility issues with any of the plugins. After running the checker I got warnings for both Nextgen and Nextgen Pro.

    Nextgen Warnings:
    FILE: /public_html/wp-content/plugins/nextgen-gallery/non_pope/class.photocrati_settings_manager.php
    ——————————————————————————————————————————————————————————
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ——————————————————————————————————————————————————————————
    203 | WARNING | Method name “C_Photocrati_Settings_Manager_Base::__toArray” is discouraged; PHP has reserved all method names with a double underscore prefix for future use
    ——————————————————————————————————————————————————————————

    FILE: /public_html/wp-content/plugins/nextgen-gallery/freemius/includes/fs-essential-functions.php
    —————————————————————————————————————————————
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    —————————————————————————————————————————————
    165 | WARNING | Function name “__fs” is discouraged; PHP has reserved all method names with a double underscore prefix for future use
    —————————————————————————————————————————————

    FILE: /public_html/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/ngglegacy/nggallery.php
    ——————————————————————————————————————————-
    FOUND 0 ERRORS AND 4 WARNINGS AFFECTING 4 LINES
    ——————————————————————————————————————————-
    185 | WARNING | INI directive ‘safe_mode’ is deprecated since PHP 5.3 and removed since PHP 5.4
    187 | WARNING | INI directive ‘safe_mode’ is deprecated since PHP 5.3 and removed since PHP 5.4
    188 | WARNING | INI directive ‘safe_mode’ is deprecated since PHP 5.3 and removed since PHP 5.4
    190 | WARNING | INI directive ‘safe_mode’ is deprecated since PHP 5.3 and removed since PHP 5.4
    ——————————————————————————————————————————-

    FILE: /public_html/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/ngglegacy/admin/overview.php
    ————————————————————————————————————————————
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ————————————————————————————————————————————
    28 | WARNING | INI directive ‘safe_mode’ is deprecated since PHP 5.3 and removed since PHP 5.4
    ————————————————————————————————————————————

    FILE: /public_html/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/attach_to_post/templates/tinymce_placeholder.php
    ———————————————————————————————————————————————————–
    FOUND 0 ERRORS AND 4 WARNINGS AFFECTING 4 LINES
    ———————————————————————————————————————————————————–
    2 | WARNING | Possible use of ASP style opening tags detected. ASP style opening tags have been removed in PHP 7.0. Found: <%- ref %>” data-shortcode=…
    3 | WARNING | Possible use of ASP style opening tags detected. ASP style opening tags have been removed in PHP 7.0. Found: <%- nextgen_gallery %></h3>
    4 | WARNING | Possible use of ASP style opening tags detected. ASP style opening tags have been removed in PHP 7.0. Found: <%- edit %>” class=”nggPlac…
    7 | WARNING | Possible use of ASP style opening tags detected. ASP style opening tags have been removed in PHP 7.0. Found: <%- remove %>” class=”nggPl…
    ———————————————————————————————————————————————————–

    FILE: /public_html/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/nextgen_data/package.module.nextgen_data.php
    —————————————————————————————————————————————————-
    FOUND 0 ERRORS AND 2 WARNINGS AFFECTING 2 LINES
    —————————————————————————————————————————————————-
    1168 | WARNING | INI directive ‘safe_mode’ is deprecated since PHP 5.3 and removed since PHP 5.4
    3756 | WARNING | INI directive ‘safe_mode’ is deprecated since PHP 5.3 and removed since PHP 5.4
    —————————————————————————————————————————————————-

    FILE: /public_html/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/nextgen_gallery_display/package.module.nextgen_gallery_display.php
    ————————————————————————————————————————————————————————————
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ————————————————————————————————————————————————————————————
    1974 | WARNING | Method name “C_Displayed_Gallery_Source_Manager::__sort_by_name” is discouraged; PHP has reserved all method names with a double underscore prefix for future use
    ————————————————————————————————————————————————————————————
    Update Available: 2.2.14; Current Version: 2.2.10;

    Nextgen Pro Warnings:
    FILE: /public_html/wp-content/plugins/nextgen-gallery-pro/modules/stripe/stripe-sdk/lib/Stripe/Object.php
    ———————————————————————————————————————————————————
    FOUND 0 ERRORS AND 2 WARNINGS AFFECTING 2 LINES
    ———————————————————————————————————————————————————
    239 | WARNING | Method name “Stripe_Object::__toJSON” is discouraged; PHP has reserved all method names with a double underscore prefix for future use
    254 | WARNING | Method name “Stripe_Object::__toArray” is discouraged; PHP has reserved all method names with a double underscore prefix for future use
    ———————————————————————————————————————————————————

    I know the plugin has reported false positives, and that I’m running an older version at the moment. So I wanted to check with you and see if this is a false positive, or because the plugin just needs to be updated, and if so, is the current version PHP7 compatible?

    • This topic was modified 1 year, 8 months ago by  RachelHKay.
Viewing 5 replies - 1 through 5 (of 5 total)
  • next gen is php 7 ready

    look here my testsite with php 7.1.9

    Link

    Thanks for the link maverik01, I really appreciate it.

    Plugin Author Imagely

    (@imagely)

    @maverik01 – Thanks for sharing!

    @rachelhkay – We are aware that the PHP checker can provide information that is valuable but not necessarily defining as to compatibility. To the best of our knowledge and testing we are compatible with the latest stable releases of PHP and generally recommend at least using PHP 7.0.x as secure and stable to use.

    Thanks!

    – Cais.

    NextGen DEFINITELY does not work with anything above 7.0. Imagely, I’m surprised you’d even recommend upgrading to it as it causes 500 internal server errors.

    Plugin Author Imagely

    (@imagely)

    @eventermom – Please note the specific message we write to the Dashboard about specific versions of PHP that have a bug causing problems such as what you are describing (although in a very limited fashion). Please also note the sticky topics in the forums related to these specific versions as well.

    Please, also, start your own topic so we can try to help you with your specific issue on your specific site as the case may be.

    See https://make.wordpress.org/support/handbook/forum-welcome/#post-in-the-best-place

    Thanks!

    – Cais.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Is Nextgen PHP7 Compatible?’ is closed to new replies.