Support » Plugin: BackWPup - WordPress Backup Plugin » Is Multipart Upload disabled/broken in 3.6.10?

  • 3.6.10 gives us an error :
    [23-Jul-2019 10:42:08] 1. Trying to send backup file to S3 Service …
    [23-Jul-2019 10:42:08] Connected to S3 Bucket “XoXoXoX” in us-west-XoX
    [23-Jul-2019 10:42:08] Checking for not aborted multipart Uploads …
    [23-Jul-2019 10:42:08] Starting upload to S3 Service …
    [23-Jul-2019 10:44:19] ERROR: Allowed memory size of 1073741824 bytes exhausted (tried to allocate 5242912 bytes)
    =======================================
    Details :
    PHP 7.3
    php.ini -> memory_limit = 1024M
    filesize =
    1172170230 backwpup_Q56F5CBU01_XoX_dailyfull_2019-07-23_10-37-26.tar.gz
    =======================================
    Our backups ran fine under version 3.6.0.
    And that version has a checkbox for Multipart Uploads.
    3.6.10 does not.
    ============================================================
    I tried another test : php.ini -> memory_limit = 3072M
    I still got the same error :

    ERROR: Allowed memory size of 1073741824 bytes exhausted (tried to allocate 5242912 bytes)

    …but at least the file got uploaded to S3.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Per Google, 1073741824 bytes = 1024 Mebibytes
    So it looks like there’s some 1024 limit being set somewhere…but where?

    And like I said, 3.6.0 works fine, but 3.6.10 does not.
    I don’t think raising my php.ini memory_limit to even higher values is a safe solution.

    Thanks in advance!

    I found something else…
    wp-config.php –> define( ‘WP_MAX_MEMORY_LIMIT’, ‘1024M’ );

    When I set
    php.ini –> memory_limit = 2048M
    and
    wp-config.php –> define( ‘WP_MAX_MEMORY_LIMIT’, ‘2048M’ );

    …the error disappears, and all works fine. But we can’t keep raising these values ad infinitum…especially if our backup is larger than our available RAM.

    So, my conclusion is :
    3.6.0 – setting for Multipart Uploads allow larger file uploads to S3
    3.6.10 – NO SETTING for Multipart Uploads, so it is broken/not allowed anymore.

    Correct?
    Can it be fixed?
    Is there an option someplace where I can re-enable it?

    Thanks in advance!

    Plugin Support duongcuong96

    (@duongcuong96)

    Hi @victorkun
    it was an issue after we upgrade the AWS S3, our devs are currently investing in 🙂
    Will be back to you when I have something new

    Thanks for the reply!
    Looking forward for the updates/fixes…. 8)

    Plugin Support duongcuong96

    (@duongcuong96)

    @victorkun
    btw, in the meantime, you can temproary using the older 3.6.9 version 🙂

    Plugin Support duongcuong96

    (@duongcuong96)

    Hi @victorkun
    Please update the plugin to the latest 3.7
    Thanks!

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.