WordPress.org

Forums

Is its parent directory writable by the server? (13 posts)

  1. ldaroche
    Member
    Posted 6 years ago #

    Help!
    I get this message when trying to upload media:
    Unable to create directory /home/paulo/public_html/wp-content/uploads/2009/02. Is its parent directory writable by the server?

    Where do I go/what do I do to make it writeable?

  2. t31os
    Member
    Posted 6 years ago #

    FTP or CPanel file manager...

    Permissions can also be referred to as CHMOD.

    It's referring to the permissions on the uploads folder more then likely...

  3. srilatha_marru
    Member
    Posted 6 years ago #

    Hi, I have the same problem. I have changed the permission of the wp-content and its sub directories to 777. But i am still getting the error "Is its parent directory writable by the server?".

    what else i could be missing? Please let me know.

  4. srilatha_marru
    Member
    Posted 6 years ago #

    Actually, 777 works but the error was due to other reason. I had wrong path specified in wordpress "miscellaneous" settings. It rather should be "wp-content/uploads". Now i am able to upload documents.

  5. t31os
    Member
    Posted 6 years ago #

    If the problem wasn't the permissions then set them back to what they were...

    You should "ideally" avoid 777 where possible...

  6. cattleproder
    Member
    Posted 5 years ago #

    I just fixed this for a customer and the permissions was NOT the issue. On the servers where I work a permissions set of 0777 will get rejected because that is just begging to be hacked. The problem came from the upload path specified in the WP. I didn't change it in the admin panel, I changed it in the DB to reflect the FULL server path. So your /home/user/public_html/wp-content/uploads and that got the issue fixed. Peace.

  7. bwoolbright
    Member
    Posted 5 years ago #

    I've never handled a problem like this, so how do you change the path in the DB to reflect the FULL server path? I think that's my problem.

  8. Shane G
    Member
    Posted 5 years ago #

    Hi,

    Assign 766 recursive permissions to wp-contents folder.
    Disable all the plugins and enable it one by one to find out the culprit
    Make sure that you have set proper path for upload directory in wordpress admin area

    Thanks,

    Shane G.

  9. Trafficx
    Member
    Posted 5 years ago #

    I unchecked the 'Organize my uploads into month- and year-based folders' box. Unchecking this box and saving the changes is what solved my problem.

  10. ElectronicCarpenter
    Member
    Posted 5 years ago #

    Try This...
    http://wordpress.org/support/topic/301275
    This worked for me ;)

  11. gilig
    Member
    Posted 5 years ago #

    thanks to Forrest_Snyder, he says:

    Go to DASHBOARD > MISCELLANEOUS > UPLOADING FILES

    Set:

    Store uploads in this folder into > wp-content/uploads (which is the default)

    simple!

  12. elida
    Member
    Posted 5 years ago #

    thanks srilatha_marru. misc setting worked.

  13. hubbygrove
    Member
    Posted 5 years ago #

    Hi All,

    settings>miscellaneous>Store uploads in this folder>wp-content/uploads

    I transferred the backup from inmotion to media temple and I just changed the path to "wp-content/uploads" and it worked for me.

    I would like to let you know that inmotion hosting sucks and I don't know why they are get awards..Surprising!!!!
    If your blog earn more than 1000 page views a day then never host with inmotion. They don't only charge heavy amount but they will bann your account for more traffic. I have been through this. I can forward all the mails from them for proof (hubbygrove@gmail.com).

Topic Closed

This topic has been closed to new replies.

About this Topic