Support » Theme: evolve » Is it possible to disable google maps?

  • Hello everybody

    I like this theme overall and I’ve been using it on my nutrition data blog FooDosage.com, but there’s something bugging me: The pages often seem to load for an eternity, because they’re waiting for maps.googleapis.com. I understand this is used for the contact sheet, but I don’t use a contact sheet and if I used one, I wouldn’t need a map on it. I also understand that the page is otherwise fully loaded and readable within seconds, but it annoys me anyway that there is this little loading icon just going on and on and on.

    Is there a way to disable or remove google maps functionality (and loading) from the theme?

    Many thanks in advance and have a great day.

Viewing 14 replies - 1 through 14 (of 14 total)
  • Donna

    (@donnawpadmin)

    Your site loads find for me. Under 1.5 seconds.

    And fyi…read your T & C …no one needs your “permission” to link “to” any page on your site. Embeds, of course, are different. But the internet is public, not private. Anyone can link to anything they want. https://lorelle.wordpress.com/2006/07/06/do-you-need-permission-to-link-to-someones-content/
    And I have Google maps on my site, and on another site that used this theme, and I don’t think it slows the site down at all…

    If you want to know exactly what’s loading how on your site, use Chrome browser, and install the yslow extension…

    It varies. Right now it’s quick for me too. Sometimes it takes half a minute. I know the site isn’t actually slowed down by it. I just don’t like the loading icon.

    And you’re probably right about the T&C. It’s a free template I never bothered much with ^^

    But Thank you for the tips.

    Donna

    (@donnawpadmin)

    I don’t have a loading icon…are you talking about the one on the browser tab itself? Or somewhere on the page…? because it completes for me.

    • This reply was modified 6 months, 2 weeks ago by  Donna.

    The one on the browser itself. I know it’s irrelevant, but it irritates me.

    Donna

    (@donnawpadmin)

    I know what you are talking about, but it didn’t do it on mine. Try disabling all browser extensions in whatever browser you are using, and maybe even switch browser’s to make sure it’s the site…

    I’m on my phone right now so can’t check much, but I doubt it is the theme. Do you have jetpack installed? Sometimes that one causes issues… It has so many modules. Some are great, others are buggy.

    I tried with firefox, opera, tor, even chrome (no extensions on that one), but when it’s there, it’s with all of them. But it is intermittent and tonight it seems to not want to rear its ugly head.

    I do have jetpack, but I don’t know if that could be it. When the site is loading, the broswer message is “waiting for maps.googleapis.com. I think the fault lies with google, but if I could just remove this functionality I don’t need from the theme, I’d be happy.

    Rodario, I don’t think this is coming from the Evolve theme. When I look at the page source of your site, I see this code in the source html of your home page (at line 6)
    <link rel='dns-prefetch' href='//maps.googleapis.com' />

    I used Google maps on internal pages of my own Evolve-based site, but I don’t see any dns-prefetch links for the Google maps api — not even on the the pages which display the maps (not the theme contact page, but from a third-party plugin).

    Now I may be mistaken, because I also opted to disable the map on the “contact” page, simply by not entering address information in the Theme Options/Contact section — so maybe that is the difference — so a starting point for you may be to check to be sure to clear out any information in the address field for that section. Then clear all caches & check your home page source code to see whether you are still seeing the dns-prefetch link.

    I also have other things that might impact site display — for example, I use cloudflare, which does make its own changes to source code — but I would suggest that to debug you might disable all plugins, and then reload your home page and view source code to see whether that dns-prefetch element is still there.

    If not, you could enable plugins one by one to see which is responsible for the code. Plugins that supposedly optimize or speed up your site might be the most likely to add the pre-fetch link.

    Donna

    (@donnawpadmin)

    Jetpack has a lot of modules. They are not all bad, some are quite good. But the Google maps, and the contact module is horrible, check to see if it is enabled in Jetpack settings, and if it is, turn it off. You don’t have to disable the whole Jetpack plugin. Also check for any other modules (services) in Jetpack that are not being used, and if you aren’t using them specifically, turn off the module.

    Theme Author Romik84

    (@romik84)

    Hello

    Theme has no issue with googel Map API. For your help I suggest you disable google map api using below option
    Theme options -> Advance -> Enable Google Map Scripts
    Uncheck this box and save. Your google map script not load now.

    Thank you

    @abigailm and @donnawpadmin: Thank you so much for all those tips. I will try them to see if I can fix the problem.

    @romik84: Thank you for your reply. Small problem: I don’t have any “Theme options” in my dashboard. I have been looking for such an option under “Customize” after googling why I don’t have theme options and finding out they were disabled some wordpress versioins ago, but couldn’t find it.

    Theme Author Romik84

    (@romik84)

    Hello

    Please active Redux Framework Plugin then after check your option available
    Appearance -> Theme Options

    Thank you

    Oh, thank you 🙂

    Donna

    (@donnawpadmin)

    OH wow…yes, you need the stupid redux plugin for Evolve…not a fan, but that’s how they coded the theme…oops. Yeah…the two go hand-in-hand…without it, you are missing most the themes capability…

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Is it possible to disable google maps?’ is closed to new replies.