Support » Plugin: Sitemap by BestWebSoft » Is GoogleSiteMap compatible with PHP 5.6?

  • Resolved steventhomasnz

    (@steventhomasnz)


    I host with WP-Engine and they are about to upgrade PHP from 5.3 to 5.6. I’d like reassurance your plugin will work when they upgrade PHP.

    I asked because your plugin comes up with a warning using the PHP Compatibility Checker:

    Name: Google Sitemap by BestWebSoft

    FILE: /nas/content/live/balagan/wp-content/plugins/google-sitemap-plugin/bws_menu/bws_menu.php
    ————————————————————————————————–
    FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
    ————————————————————————————————–
    163 | WARNING | INI directive ‘safe_mode’ is deprecated since PHP 5.3 and removed since PHP 5.4.
    ————————————————————————————————–

Viewing 1 replies (of 1 total)
  • Plugin Author bestwebsoft

    (@bestwebsoft)

    Hi,

    Thank you for contacting us.

    Don’t worry about that, it is not an error and it won’t cause any compatibility problems.
    While gather system information for report our plugin calls ini_get( ‘safe_mode’ ) function, which will simply return false on PHP version higher than 5.4 with no errors.

    Sincerely,
    BestWebSoft Support Team

Viewing 1 replies (of 1 total)
  • The topic ‘Is GoogleSiteMap compatible with PHP 5.6?’ is closed to new replies.