Support » Plugin: Daisycon prijsvergelijkers » Is deze update getest tot wordpress 4.8 ?

  • Is deze plugin up to date tot wordpress 4.8.2 ?
    Want ik zie dat deze plugin al 1 jaar niet is geupdate !

    Vriendelijke groeten ,
    Marcel

Viewing 1 replies (of 1 total)
  • elusive2k

    (@elusive2k)

    Beste Digi360,

    Ik heb zojuist deze plugin geinstalleerd op WordPress 4.9.
    Deze wou niet activeren i.v.m. een fatale fout die werd veroorzaakt, op een lagere wordpress versie zou dit tot een HTTP 500 error leiden.
    Nu heb ik een beetje gedebugt en het probleem lijkt te zitten in de file: wp-content/plugins/daisycon/includes/database.php
    Dit probleem is te verhelpen door alle code in database.php te vervangen voor onderstaande code:

    <?php 
    /* Daisycon prijsvergelijkers
     * File: database.php
     * 
     * To create the database for the plugin and to update the tables if necessary.
     * 
     */
    
    global $wpdb;
    $table_name = $wpdb->prefix.'daisycon_tools';
    
    if($wpdb->get_var("SHOW TABLES LIKE '{$table_name}'") != $table_name)
    {
    	$defaultTablePrefix = $wpdb->prefix.'daisycon_tools';
    
    	// Categories table
    	$sql_mediaid = "
    		CREATE TABLE ".$defaultTablePrefix." (
    			media_id int(11) NOT NULL
    		) ENGINE=MyISAM  DEFAULT CHARSET=utf8 COLLATE=utf8_unicode_ci;";
    
            require_once( ABSPATH . 'wp-admin/includes/upgrade.php' );
            dbDelta( $sql_mediaid );
    }
    ?>

    EDIT: deze plugin zorgt overigens voor de foutmelding in PHPMyAdmin “Token does not match”, ik kan de table niet legen of verwijderen die wordt aangemaakt door database.php

    • This reply was modified 2 years ago by elusive2k.
Viewing 1 replies (of 1 total)
  • The topic ‘Is deze update getest tot wordpress 4.8 ?’ is closed to new replies.