WordPress.org

Forums

Contextual Related Posts
[resolved] Is CRP Compatible With Twitter Card? (8 posts)

  1. dewangibson
    Member
    Posted 2 years ago #

    Contextual related posts has been great. However, I had to deactivate it once I installed a Twitter card. If both are activated the Twitter card will only show the contextual related post links in the area that's supposed to show the summary of the story, which defeats the purpose of having a Twitter card. Is there any way I can get contextual related posts to NOT show up in my Twitter card?

    Thanks for your help.

    http://wordpress.org/extend/plugins/contextual-related-posts/

  2. Ajay
    Member
    Plugin Author

    Posted 2 years ago #

    Could you please elaborate? Screenshots of your site / link will help.

    I've not had any user report any issue with the plugin and Twitter cards and I don't use Twitter cards on my site.

  3. dewangibson
    Member
    Posted 2 years ago #

    Sure. Here's the tweet: http://tinypic.com/r/sl3509/5.

    You'll notice that instead of an article summary only the related posts titles are showing.

  4. Ajay
    Member
    Plugin Author

    Posted 2 years ago #

    Could you also please let me know how the Twitter card summary works on your site. Is there a way I can reproduce the problem?

  5. dewangibson
    Member
    Posted 2 years ago #

    Twitter Card Meta is a plugin that expands Tweets to an article summary. You can't immediately reproduce the problem because after downloading Twitter Card you have to apply for the program (Twitter takes about a week to approve). This is how the Twitter card tweet looks after deactivating Related Posts: http://tinypic.com/r/kb2vr/5

    For some reason the Related Posts text is getting into the Twitter card, as shown in my previous post.

  6. Ajay
    Member
    Plugin Author

    Posted 2 years ago #

    Dewan,

    It seems to be because Related Posts uses the_content filter to add the posts in, which seems to be clashing with Twitter Card Meta.

    You might want to try using the Manual Install as detailed in the FAQ by modifying your theme and choosing where to display the related posts.

    Also, are you running the latest version of both plugins?

  7. dewangibson
    Member
    Posted 2 years ago #

    Yes, I'm running the latest versions of both. I'll try the manual install. Thanks for your help.

  8. Ajay
    Member
    Plugin Author

    Posted 2 years ago #

    You're welcome. Did the manual install work?

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Contextual Related Posts
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic