Support » Plugin: BackWPup - WordPress Backup Plugin » Is BackWPUP compatible with PHP 7?

  • I ran WPEngine’s PHP Compatibility checker on my site and it returned a long list of PHP 7 compatibility errors for BackWPUp. Are these on the roadmap to be fixed?

    FILE: /wp-content/plugins/backwpup/vendor/PEAR/HTTP/Request2.php
    --------------------------------------------------------------------------------FOUND 2 ERRORS AFFECTING 2 LINES
    -------------------------------------------------------------------------------- 929 | ERROR | The use of function set_magic_quotes_runtime is discouraged from PHP version 5.3 and forbidden from PHP version 7.0
     944 | ERROR | The use of function set_magic_quotes_runtime is discouraged from PHP version 5.3 and forbidden from PHP version 7.0
    --------------------------------------------------------------------------------
    
    FILE: /wp-content/plugins/backwpup/vendor/SwiftMailer/classes/Swift/ByteStream/FileByteStream.php
    --------------------------------------------------------------------------------FOUND 2 ERRORS AFFECTING 2 LINES
    -------------------------------------------------------------------------------- 87 | ERROR | INI directive 'magic_quotes_runtime' is deprecated from PHP 5.3 and forbidden from PHP 5.4.
     91 | ERROR | INI directive 'magic_quotes_runtime' is deprecated from PHP 5.3 and forbidden from PHP 5.4.
    --------------------------------------------------------------------------------
    
    FILE: /wp-content/plugins/backwpup/vendor/SwiftMailer/classes/Swift/KeyCache/DiskKeyCache.php
    --------------------------------------------------------------------------------FOUND 4 ERRORS AFFECTING 4 LINES
    -------------------------------------------------------------------------------- 180 | ERROR | INI directive 'magic_quotes_runtime' is deprecated from PHP 5.3 and forbidden from PHP 5.4.
     187 | ERROR | INI directive 'magic_quotes_runtime' is deprecated from PHP 5.3 and forbidden from PHP 5.4.
     207 | ERROR | INI directive 'magic_quotes_runtime' is deprecated from PHP 5.3 and forbidden from PHP 5.4.
     213 | ERROR | INI directive 'magic_quotes_runtime' is deprecated from PHP 5.3 and forbidden from PHP 5.4.
    --------------------------------------------------------------------------------
    
    FILE: /wp-content/plugins/backwpup/vendor/SwiftMailer/classes/Swift/Transport/SimpleMailInvoker.php
    --------------------------------------------------------------------------------FOUND 1 ERROR AFFECTING 1 LINE
    -------------------------------------------------------------------------------- 33 | ERROR | INI directive 'safe_mode' is deprecated from PHP 5.3 and forbidden from PHP 5.4.
    --------------------------------------------------------------------------------
    
    FILE: /wp-content/plugins/backwpup/vendor/OpenCloud/Common/Base.php
    --------------------------------------------------------------------------------FOUND 1 ERROR AFFECTING 1 LINE
    -------------------------------------------------------------------------------- 312 | ERROR | 'resource' is a reserved keyword introduced in PHP version 7.0 and cannot be invoked as a function (T_STRING)
    --------------------------------------------------------------------------------
    
    FILE: /wp-content/plugins/backwpup/vendor/OpenCloud/Common/Collection/ResourceIterator.php
    --------------------------------------------------------------------------------FOUND 1 ERROR AFFECTING 1 LINE
    -------------------------------------------------------------------------------- 200 | ERROR | 'resource' is a reserved keyword introduced in PHP version 7.0 and cannot be invoked as a function (T_STRING)
    --------------------------------------------------------------------------------
    
    FILE: /wp-content/plugins/backwpup/vendor/OpenCloud/Common/Collection.php
    --------------------------------------------------------------------------------FOUND 1 ERROR AFFECTING 1 LINE
    -------------------------------------------------------------------------------- 306 | ERROR | 'resource' is a reserved keyword introduced in PHP version 7.0 and cannot be invoked as a function (T_STRING)
    --------------------------------------------------------------------------------
    
    FILE: /wp-content/plugins/backwpup/vendor/OpenCloud/Common/Service/AbstractService.php
    --------------------------------------------------------------------------------FOUND 1 ERROR AFFECTING 1 LINE
    -------------------------------------------------------------------------------- 142 | ERROR | Function name, class name, namespace name or constant name can not be reserved keyword 'resource' (since version 7.0)
    --------------------------------------------------------------------------------
    
    FILE: /wp-content/plugins/backwpup/vendor/OpenCloud/Identity/Service.php
    --------------------------------------------------------------------------------FOUND 5 ERRORS AFFECTING 5 LINES
    --------------------------------------------------------------------------------  94 | ERROR | 'resource' is a reserved keyword introduced in PHP version 7.0 and cannot be invoked as a function (T_STRING)
     121 | ERROR | 'resource' is a reserved keyword introduced in PHP version 7.0 and cannot be invoked as a function (T_STRING)
     135 | ERROR | 'resource' is a reserved keyword introduced in PHP version 7.0 and cannot be invoked as a function (T_STRING)
     164 | ERROR | 'resource' is a reserved keyword introduced in PHP version 7.0 and cannot be invoked as a function (T_STRING)
     192 | ERROR | 'resource' is a reserved keyword introduced in PHP version 7.0 and cannot be invoked as a function (T_STRING)
    --------------------------------------------------------------------------------
    
    FILE: /wp-content/plugins/backwpup/vendor/OpenCloud/OpenStack.php
    --------------------------------------------------------------------------------FOUND 7 ERRORS AFFECTING 7 LINES
    -------------------------------------------------------------------------------- 132 | ERROR | 'resource' is a reserved keyword introduced in PHP version 7.0 and cannot be invoked as a function (T_STRING)
     136 | ERROR | 'resource' is a reserved keyword introduced in PHP version 7.0 and cannot be invoked as a function (T_STRING)
     206 | ERROR | 'resource' is a reserved keyword introduced in PHP version 7.0 and cannot be invoked as a function (T_STRING)
     210 | ERROR | 'resource' is a reserved keyword introduced in PHP version 7.0 and cannot be invoked as a function (T_STRING)
     396 | ERROR | 'resource' is a reserved keyword introduced in PHP version 7.0 and cannot be invoked as a function (T_STRING)
     397 | ERROR | 'resource' is a reserved keyword introduced in PHP version 7.0 and cannot be invoked as a function (T_STRING)
     400 | ERROR | 'resource' is a reserved keyword introduced in PHP version 7.0 and cannot be invoked as a function (T_STRING)
    --------------------------------------------------------------------------------
    
    FILE: /wp-content/plugins/backwpup/inc/class-job.php
    --------------------------------------------------------------------------------
    FOUND 1 ERROR AFFECTING 1 LINE
    --------------------------------------------------------------------------------
     767 | ERROR | INI directive 'safe_mode_protected_env_vars' is deprecated from PHP 5.3 and forbidden from PHP 5.4.
    --------------------------------------------------------------------------------
    
    FILE: /wp-content/plugins/backwpup/inc/class-page-settings.php
    --------------------------------------------------------------------------------
    FOUND 1 ERROR AFFECTING 1 LINE
    ------------------------------------------------------------------------------------------------
     451 | ERROR | INI directive 'safe_mode' is deprecated from PHP 5.3 and forbidden from PHP 5.4.
    --------------------------------------------------------------------------------

    https://wordpress.org/plugins/backwpup/

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Daniel Hüsken

    (@danielhuesken)

    I have tested it with PHP 7, but i will have a look for the thinks maked hiere 😉

    The vendos will be updated with th next major release.

    Plugin Author Daniel Hüsken

    (@danielhuesken)

    Ok, many of them cames from vendors. That will be upgrated in a later release.
    The other will not affect the functonality but i will remove them.

    Months have passed and these errors are not fixed yet. Do you have any plans for these to be fixed or a quick work around?

    I got the same error. Is this going to be fixed soon?

    Same here…

    Same with me. No updates on the plugin.

    Has someone tested it productive? Is everything working like a charm after all?

    I’ve been living dangerously for the past few months and using it with PHP 7. No issues.

    Ran the PHP 7 Compatibility checker today and BackWPup has Warnings:2 Errors:33.

    So to date the latest update is still not PHP 7 compatible according to this test.

    Hi @rixtertrader, BackWPup runs fine on PHP 7. There are some minor issues with some of the libraries used that will be fixed in a future version. However I’m running BackWPup on a personal site on PHP 7.0 without issue.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Is BackWPUP compatible with PHP 7?’ is closed to new replies.