Support » Plugin: SendPress Newsletters » Is anyone using “Settings > Permissions” successfully?

  • Resolved dgranja

    (@dgranja)


    I would like to give Editors the ability to create and send email. Has anyone else been able to successfully assign permissions to do so?
    There is a great Sendpress page for doing so if you navigate to “Settings > Permissions”. However, when I click the appropriate checkboxes and click “Save”, the screen just resets, unchecks all the checkboxes, and I’m back where I started. I’ve tried this in IE, Firefox, Opera, and Chrome, all with the same result, and with other plugins disabled. Everything else in SendPress works just great.
    My settings:
    WordPress Version: 4.9.1
    SendPress Version: 1.8.12.18
    PHP Version: 7.0.26
    PHP Memory Limit: 256 MByte
    PHP Memory Used: 11.22 MByte
    MySQL Version: 5.5.5

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author itdoug

    (@itdoug)

    That’s weird. It works on my test machine. Have you tried activating a different theme temporarily? Sometimes those conflict too. If there are any errors in your server logs those could help too. Drop us a line in our contact form if you want to let us take a look for you. I’s at the bottom of the page: https://www.sendpress.com/

    Thread Starter dgranja

    (@dgranja)

    I had a little back and forth with support, but it turned out to be related to a role I had created but not assigned any capabilities to. Apparently Sendpress attempted to iterate through the roles to build its table, but threw a fatal php error when it didn’t handle a null value. So, it didn’t complete building its table or completing its logic. After I deleted the role, everything worked perfectly!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Is anyone using “Settings > Permissions” successfully?’ is closed to new replies.