Support » Plugin: WP Job Manager » Is anyone facing this problem with filled or non filled positions?

  • Resolved ibiza69

    (@ibiza69)


    Hi to all, I wanted to ask you for a big favor!

    If you are facing same problem as us and “I’m asking WP Job Manager users”, as the developer says there isn´t any problem with this I’m about to explain:

    1. We have 3 PAGES (at Administrate My Job Offers section), of job offers published (and live) in a site for testing purposes.

    2. When we select in PAGE 1 of job listings admin, one of the job offers published as “position filled”, it shows well the message “this position has being filled”.

    3. BUT, when we navigate to PAGE 2, to select another job offer as filled, there comes the same message saying: “This position has already being filled”.

    4. When we return for example to PAGE 1 or PAGE 3 of our job offers, same message appears: “This position has already being filled”.

    5. When then we select the job offer selected in 1st place as “filled”, as “not filled”, it shows well the message: “this position has not being filled”.

    6. BUT, and again, when we jump to PAGE 2 to navigate thru our jobs published, there comes a message saying: “this position has not being filled”…

    7. When we return for example to PAGE 1 or PAGE 3 of our job offers, same message appears: “this position has not being filled”.

    8. You can keep navigating thru PAGE 1,2,3 that the same message keeps on showing, and can´t get reach off it. Same exactly thing happens with “positions marked as filled” and with ” positions marked as not filled”.

    NOTE: This “only happens” since version 1.32.0 and up…

    * This “doesn´t happen” with versión 1.31.3 and and earlier..

    – We have both versions installed in test sites, in one site version 1.31.3 and in the other version 1.34.0.

    – We have none other plugins installed.

    – We have default wordpress Theme installed.

    Can anyone try this if you have a few job offers plublished that reach 2-3 pagination at “administrate my job offers” section?

    Developer doesn´t want to check and leads us (as always) to issues with themes or other plugins.

    We really think it´s a configuration bug and if you check and face same problem, probably developer with take care of it.

    Thanks A LOT for your help!! This will be good for all of us, if it´s really a developing or programming problem.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Yes, that happens to us, too, I agree that it looks like a bug.

    Also, it’s really easy to test–just have more than one page of job posts on the [job_dashboard] and mark one job as filled on one page of the dashboard (prompting the [Job Title] has been filled message. After that, navigating to subsequent pages of jobs listed on the [job_dashboard] will keep generating an erroneous This position has already been filled error message each time.

    We would also appreciate this being looked at and a resolution!

    Thank you @hastibe !!

    Plugin Contributor Richard Archambault

    (@richardmtl)

    Hi!

    I think I get what you’re saying, but it’s still a bit confusing for me. Can you show me exactly how to reproduce this on your site, and share a link to it? Give me exact steps to do so. Or, you can make a screencast of it and share a link to the screencast here.

    Thanks!

    ibiza69

    (@ibiza69)

    Hi @richardmtl thanks for your attention.

    We’ve tryed to record an screencast for you, hopefully you underestand the video. If you see, we mark a position as filled and keeps on showing the filled position message in other pages, then we go back and select position as not filled and same thing, keeps showing position not filled in other pages, then we turn back to page one and same thing, keeps showing message of position not filled and that message never goes away. And this is only selecting one position, if you select more, it goes crazy.

    https://streamable.com/i8n7y

    Please let us know if you underestand whats happening. Thank you.

    Plugin Contributor Richard Archambault

    (@richardmtl)

    Thanks for the clear screencast! That certainly helped, and I was able to reproduce on my test site! So I opened up a bug report here:

    https://github.com/Automattic/WP-Job-Manager/issues/1912

    Since we now have that bug report, I’ll mark this thread as closed. If you have any further thoughts, feel free to comment on that issue, or subscribe to it for updates!

    Hi, after updating to version 1.34.1, problems are not solved. Same exactly problems with positions filled and non filled.

    Any feedback or information? Do you think this will be solved some day?

    Thank you.

    Plugin Contributor Richard Archambault

    (@richardmtl)

    As I noted on the issue, it has not been worked on and a fix was not included in 1.34.1. I’ll close this thread again as we can continue the conversation on Github if necessary.

    https://github.com/Automattic/WP-Job-Manager/issues/1912

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.