WordPress.org

Forums

WP Super Cache
Is any there any way to exempt a page from caching? (3 posts)

  1. xprt007
    Member
    Posted 1 year ago #

    Hi

    I am NOT very conversant with this plugin & certainly NOT a coder.
    I am using quite a number of plugins on a Buddypress-based community site on a shared server.
    Using super cache, together with jsDelivr - WordPress CDN Plugin has helped speed it up, but there is something causing me some headache of late. I am pulling some page info from a php-based feed from giveawayoftheday.com, where we have a different type of free software offered everyday & if you have to download it, it must be done within shown period of 24 hours.

    Unfortunately, it seems because of caching, this information is not updated on time & you have software for a day or 2 or even more before being shown & by this time, it is long expired & cannot be downloaded free. This gives people who have bookmarked or come to this page to think it is a hoax as only the paid software is available.

    I think if the 2 pages, one a post, one a normal page could be exempted from caching, this could be avoided, but how do I do it? Or is there a way they can be cached BUT allow the pages to update in good time?

    I do not want all posts or pages affected.

    Is there anywhere - that I could not find - where I can say page => http://www.abc.com/affectedpage & http://www.abc.com/theotherpage .... be exempted?

    I would appreciate a response & hopefully with instructions as I am not a coder.

    Thank you in advance.

    https://wordpress.org/plugins/wp-super-cache/

  2. xprt007
    Member
    Posted 1 year ago #

    Is there a solution to this or not?
    If there is none, it would be good to know so I can move on and find a different solution to the problem of this rss page not keeping outdated content.

    I may need to add the rss content is fetched by a php script.

    I would appreciate some response.

    Regards

  3. Donncha O Caoimh
    Member
    Plugin Author

    Posted 1 year ago #

    You could define the constant DONOTCACHEPAGE in whatever page you don't want cached.

    You can also use the "Rejected URIs" section of the settings page but what you really should do is set the cache timeout to 10 minutes so pages will refresh quickly. You could also clear out the wp-content/cache/supercache/ directory at midnight so you're sure the files are reset at the right time.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP Super Cache
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.