Support » Plugin: WebP Converter for Media » is allow_url_fopen enabled required ?

  • Resolved iapprentice

    (@iapprentice)


    Hi Mateusz,

    Is “allow_url_fopen” required to be enabled for correct operation of the plugin ?
    It doesn’t appear to be listed as a requirement in the FAQ.

    The plugin appears to work and doesn’t display any errors on the settings page but I see the following warnings in my logs.

    PHP Warning: file_get_contents(): https:// wrapper is disabled in the server configuration by allow_url_fopen=0 in /home/domain.com/wp-content/plugins/webp-converter-for-media/app/Settings/Errors.php on line 82

    PHP Warning: file_get_contents(https://domain.com/wp-content/plugins/webp-converter-for-media/public/img/icon-before.png2): failed to open stream: no suitable wrapper could be found in /home/domain.com/wp-content/plugins/webp-converter-for-media/app/Settings/Errors.php on line 82

    Thanks.
    Best Regards

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Mateusz Gbiorczyk

    (@mateuszgbiorczyk)

    Hi,

    Thank you for your message.

    I have prepared for you a beta version of the plugin: https://gbiorczyk.pl/webp-converter-for-media-v1.2.5.zip

    Please download it and let me know if the warning has disappeared. If so, in the next update I will add this change and you will leave it with you.

    Thread Starter iapprentice

    (@iapprentice)

    Hi Mateusz,

    I replaced the Errors.php with the new code that you sent me.

    The PHP warnings are no longer reported in my logs.

    I also tried the 1.2.5 beta. No PHP warnings were reported.

    Thankyou for your assistance.
    Best Regards

    • This reply was modified 9 months, 4 weeks ago by iapprentice.
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘is allow_url_fopen enabled required ?’ is closed to new replies.