Support » Installing WordPress » Is 3.04 upgrade critical for sites under 3.0?

  • Hi,

    I have a bunch of sites below 3.0 that would require a lot of work to upgrade to 3.0 given the way menus are programmed, etc. Is it necessary to update to 3.04? I was hoping not to upgrade to 3.0 for a while on these sites.

    And if it is critical, do I update directly to 3.04, or do I have to step up slowly?

    Thanks.

Viewing 2 replies - 1 through 2 (of 2 total)
  • 3.0.4 is considered a critical release. It has security-hole fixes in it.

    It would be best to upgrade in steps.

    As plugins and themes aren’t always compatible, you would also want to deactivate all plugins and switch your theme to the default theme as you upgrade. Once you reach 3.0, the default theme in WordPress is replaced with a new default called ‘twentyten’ which you could also use.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Halfelf Rogue & Plugin Review Team Rep

    You can go from 2.9.2 to 3.0.4, it’s fine.

    And yeah, you really do need to consider going to 3.0.x soon. 3.1 is around the corner, and the 2.9.x branch has had NO security updates in 6 months.

    (Also you don’t HAVE to use the menus 😉 )

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Is 3.04 upgrade critical for sites under 3.0?’ is closed to new replies.