Support » Plugin: All In One WP Security & Firewall » IPv6 support in Blacklist manager

  • Since today none of the previous and newly entered IPv6 address are seen as valid address. This morning I tried to enter 2001:4b98:dc0:41:216:3eff:fe35:9f93 in the blacklist. After that attempt I got a message the earlier entered IPv6 addresses had an invalid IP-address format. I could only solve this by removing them, and the strange thing is that the new one was recognised at first en was in the list. After entering IPv4 address the newly added IPv6 address was also recognised as invalid. Did something change in the last update of the plugin, or am I the only one with this strange behaviour?

Viewing 15 replies - 1 through 15 (of 20 total)
  • Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi, currently IPv6 is not support in the Blacklist manager. You can read more about it in the following support thread.

    Thank you

    Hi @mbrsolution , thnx for your reply.

    Typical, as I have entered IPv6 addresses before without issues. Or was that because you didn’t validate them and report? Whatever the reason, please add IPv6 support ASAP as most of the attacks I currently face are from IPv6 addresses.

    Thnx in advance 🙂

    Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi,

    please add IPv6 support ASAP as most of the attacks I currently face are from IPv6 addresses.

    Do you have the following feature Rename Login Page enabled? This is located under Brute Force.

    Regards

    @mbrsolution I’m confused.
    I followed your link to the previous support thread where wpsolutions said, ” Currently IPv6 addresses in the blacklist feature are not supported.” You closed that thread saying it was a duplicate post, so I followed the link to the earlier post:
    https://wordpress.org/support/topic/possible-to-block-ipv6-addresses-2/

    In that thread, wpsolutions said:

    Actually the blacklist feature does support IPV6 addresses but it currently does not yet support ranges where you can use the “*” as for IPv4.
    If you enter the full IPv6 addresses you should be ok for now.

    Can you clarify for me?

    Thanks

    Plugin Contributor mbrsolution

    (@mbrsolution)

    @retevia, that support thread was never closed. So I am not sure what the conclusion was. Have you yourself tried black listing an IPv6 yourself?

    Regards

    Plugin Author wpsolutions

    (@wpsolutions)

    Hi @retevia and @msn450val,
    Yes at this stage you can blacklist individual IPv6 addresses but not IPv6 ranges where you use the wildcard “*”.
    Nothing was changed in that part of the code so I’m puzzled as to why you are suddenly seeing IPv6 addresses being rejected.
    If like you can contact me personally and I can get more info from you.

    Hi @wpsolutions . Like I said in the past I had no issues with single IPv6 address, but since a couple of days every old address is seen as invalid when I enter a new address, either IPv4 or IPv6. New IPv4 addresses work like a charm, but new IPv6 address I can enter at first without warning. Once I enter more IP address this IPv6 address is immediately seen as invalid. Last addresses I tried to enter were 2a02:348:71:63a7::1 and 2001:4b98:dc0:41:216:3eff:fe35:9f93 , both are normal addresses as I was able to contact their owners and report abusive use of it. I run wordpress in a cloud solution from the Dutch company TransIP, and wordpress is 5.0.3.

    Plugin Author wpsolutions

    (@wpsolutions)

    Hi @msn450val,
    Feel free to contact me directly and I can troubleshoot this further with you by adding extra debug in the code. Since there have been a few people seeing this issue I would like to get to the bottom of it.

    Hi Wpsolutions

    I have the exact same problem with IPV 6
    The following number is first stored at first
    But if you store a IPV 4 number than an error is thrown indicating the IPV 6 as invalid !!

    2607:f298:5:6000::cb6:b44c

    Why is this not a valid IPV 6 number ??
    That one is stored in the WP logfile

    Plugin Author wpsolutions

    (@wpsolutions)

    Hi @psmits1567,

    2607:f298:5:6000::cb6:b44c
    Why is this not a valid IPV 6 number ??

    It is valid and I tried adding this and other IPv6 addresses on my test site and I see no problems which is why I am rather perplexed as to why you are seeing issues.

    Are you entering the addresses separately on a new line without any additional characters such as commas, colons etc?

    If you are entering the addresses correctly, perhaps there are some hidden characters which are being added upon form submission. Can you also try doing a plugin/theme conflict test to see if another plugin or your theme might be causing this issue?

    Hi

    I van add one line containing the IPV 6 value.
    But when I save the next line containing a normal IPV 4 line, then the plugin will not save the line containing the IPV 4 line. It gives a warning stating that the value of the IPV 6 line is invalid!. If I then remove the line with the IPV 6 value the plugin saves the data
    Each line is added on a separate line, without comma’s etc
    If you add the line manually you have the same result. So to me it seems that repopulating the table contains an error.

    I have another site running on a different theme, that has the same problem. To make that sure I will retest that for you.
    Thanks fir your help!

    Plugin Author wpsolutions

    (@wpsolutions)

    Hi,
    If possible can you try another quick test?

    Momentarily deactivate all other plugins except AIOWPS and then try the blacklist tests again. Does this produce a different result?

    Plugin Author wpsolutions

    (@wpsolutions)

    Hi again,
    I think I might have an explanation for the cause of your problem and I’ve implemented a solution which will hopefully fix that.
    In summary I believe the cause might be the way different systems interpret the PHP_EOL (ie, end-of-line characters) constant. Hence I added a fix which is more robust and does not rely on that constant.
    It would be good to see if this works for you – please get in touch with me and I can give you an updated zip to try.

    Hi,

    Ok I will perform the tests you indicated today.
    And I would like to test your fix also.
    You can send the fix to peter@psmits.com
    Regards,
    Peter

    Hi Tested your input

    I have tested what happens when you do not put an enter after you paste the number in.
    If you do not give “Enter” after pasting the value on the last line, then the value is stored in the table.
    If you give “Enter” after pasting the line in the screen mask, then it gives an immediate warning.
    If you leave a blank line on screen, then you also get an error (an empty line should be ignored in my opinion).
    If you save without changing anything, then you get an invalid message.
    Only if you paste the IPV 6 number at the end of the input mask without “Enter” it will be inserted.
    But when saving it again, you will get the invalid warning.
    You can only insert IPV 6 at the end of the list on screen, without giving an “enter”.
    If I disable all plugins, then the problem still exists !

Viewing 15 replies - 1 through 15 (of 20 total)
  • You must be logged in to reply to this topic.