Support » Plugin: Age Gate » iPhone Users Cannot Access Site

  • cckhp

    (@cckhp)


    Users on iPhones appear to be unable to access the site.

    When they reach the “Age Gate” page, they see part of the logo but cannot scroll down to reach the button to request access to the site. At the bottom of the screen is the usual bar at the bottom of browsers on an iPhone and when they try to scroll down it just drags the screen up as if it were the bottom of the screen.

    Currently looking for resolution but please advise, as there are now customers on iPhones who cannot access the site. Any help appreciated, thank you.

Viewing 6 replies - 1 through 6 (of 6 total)
  • cckhp

    (@cckhp)

    UPDATE: I’ve temporarily resolved the issue with some added CSS to allow the user to scroll again (by setting age-gate’s position to absolute).

    An additional issue was that on smaller screens there was a lot of padding moving the age gate wrapper farther down the screen

    In the CSS there was styling for top: 50% and transform: translateY(-50%). I also added position: initial to the .age-gate-wrapper.

    To resolve this I used @media CSS for screens up to 480px in width for the .age-gate (top: 0, and transform: inherit).

    However, we are sure that this wasn’t an issue before, was there something in a recent update that might have caused this?

    josecostaros

    (@josecostaros)

    The same thing happens to me on my iphone.

    Thanks.

    Plugin Author Phil

    (@philsbury)

    Hi,

    Thanks for the report, I’m away this weekend so will have a look first thing when I’m back

    Thanks
    Phil

    Plugin Author Phil

    (@philsbury)

    Hi @cckhp (and @josecostaros),

    Do you have a link I can see? I’ve tested on my dev version and it’s ok (not perfect so needs a bit of a look) but would be good to see a real world example of the issue and I can look at getting the improvements into an update ASAP.

    Thanks
    Phil

    • This reply was modified 1 year ago by  Phil.
    cckhp

    (@cckhp)

    Hi @philsbury

    I’ve temporarily resolved the issue with custom CSS (noted in my update from above) and cannot remove that for an elongated period of time to show an example, as that would put our client in the same spot before where it isn’t working properly for their customers. Do you have an email or a contact form I can use to directly message you to discuss further?

    • This reply was modified 1 year ago by  cckhp.
    Plugin Author Phil

    (@philsbury)

    Hi @cckhp,

    Fully appreciate that, don’t want you to break anything on a live site. I can remove the custom styles in the inspector to see what’s happening.

    But you can email me at support@agegate.io if you need to.

    Thanks
    Phil

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘iPhone Users Cannot Access Site’ is closed to new replies.