Support » Plugin: Genesis Blocks » iPhone double tap issue with blocks

  • Resolved 2aussietravellers

    (@2aussietravellers)


    I am using the Genesis blocks page and post grid on my home page and have been experiencing the iPhone double-tap issue where the links ignore the users first tap and wait for a second one. As the majority of my readers are on mobile and an estimated 45% of smartphone users are on iPhone this impacts a lot of users experience.

    This is apparently a CSS issue where iPhone tries to replicate the desktop hover behaviour on mobile rather than being responsive to the phone experience and ignoring the hover action.

    I like the look of this block on my site and would like to know if there is a CSS fix or patch I can add to my site to remove this issue for mobile users?

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Luke Carbis

    (@lukecarbis)

    Hi @2aussietravellers – thanks for posting. I just tried your site on my iPhone and the links all work great for me, just one tap required.

    Is this something you’ve managed to fix?

    Thread Starter 2aussietravellers

    (@2aussietravellers)

    No, it is continuing to be an issue for me and other readers despite refreshing caches etc. On the homepage, if you go to the ‘latest travel articles’ section which is built with the plugin, it’s near the top and click on one of those posts (eg Bundaberg or Silver Pavilion) are you not having to two-tap, I’ve had someone new test it again to check it’s not related to me as the creator and it is still happening for them.

    @2aussietravellers I just tested a second time, and I can definitely confirm that it’s a single tap for me on iPhone 12. Tried both Bundaberg and Silver Pavilion, both work well.

    Is it possible that this is a CSS issue in older versions of Safari?

    Thread Starter 2aussietravellers

    (@2aussietravellers)

    Thanks Luke, I really appreciate your trouble to recheck. I am using an iPhone 11 for testing so a CSS issue on older phones seems possible. I will make sure the phone has the latest IOS update and check back in with those who raised the issue to see what device and version they are on to try to narrow it down further. Thanks.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.