Support » How-To and Troubleshooting » Iphone app not connecting

Iphone app not connecting

  • I downloaded the iPhone app. Tried to run it but had to upgrade blog.

    Did so, and blog is running fine, but when i add the blog then hit save i get the spinning dial thing, then goes back to main screen and crashes.

    Then when i open the app, it stays on the spinning dial and nothing happens. No error messages.

    I tried with wrong passwords and urls and it notifies me those are not correct.

    Any ideas?

    Next step would be to install a new wordpress on my server, and then import the old database and related files manually.


Viewing 15 replies - 31 through 45 (of 60 total)
  • Interestingly enough, I’ve installed 2 independent instances of wordpress on this box and both exhibit the same error messages.

    so messed around some more with things. Still getting the “can’t find the xmlrpc” error. Tried everything so far on the faq http://iphone.wordpress.org/faq/ and everything is checking out fine.

    Then I got to thinking about how my domain I am having issues is loaded with stuff. It was static before I went the wordpress route and I have a reroute link there if folks try to hit http://www.beerorkid.com/index.htm which will route them to the index.php
    (did that cuz of many links out there on the internets that pointed to the index.htm )

    this is the code of the index.htm redirect:
    <meta http-equiv='Refresh' Content='0;URL=http://www.beerorkid.com/index.php'>

    When I changed the name of the index.htm for a bit I ended up getting a different error. “nsxmlparsererrordomain error 5”

    SO I am thinking my redirect might have something to do with it.
    Thing is I had no problems posting with the first version of this wordpress iphone app.

    I also get the “nsxmlparsererrordomain error 5” error when I don’t add http:// to the blog address on the iphone app.

    I just upgraded to WP 2.6.1, still having the same problem. It takes about 3 minutes to load the http://www.mydomain.com/xmlrpc.php?rsd URL in a browser. My other blog running 2.5.1 loads that URL quickly, and also can be loaded into the iPhone app.

    Someone please help! I wanna start blogging with my iPhone already…


    honestly this is a true disappointment that this app was release with these issues…

    I had this same problem and it was driving me crazy. Turns out the theme I was using had non-UTF8 characters in it. Once I removed them from the theme the app worked great! Changing to another theme would have worked as well.

    Just follow the FAQ for the iphone app and use the w3m validator – if you get a UTF8 error you know what the problem is.

    No UTF errors at all. I’ve even tried switching back to the default theme. No go. Im at a loss here…

    Same problem …
    It was working when I was in iPhone firmware 2.0.1 with the WordPress 2.6.
    I’m now in 2.0.2 and 2.6.1 and nothing is working !
    I tried in firware 2.0 and 2.0.1 … Nothing !
    I tried WordPress 2.5.1 and 2.6 … Nothing !
    When I type mydomain.com/xmlrpc.php : XML-RPC server accepts POST requests only.
    But when I type mydomain.com/xmlrpc.php?rsd : Error 500 !
    I don’t understand what changed …
    My server ? Doesn’t support xml-rpc transfer anymore ?


    Just found !!!!!

    iPhone first post

    I just deleted these lines in the xmlrpc.php file

    <api name=”Movable Type” blogID=”1″ preferred=”false” apiLink=”<?php bloginfo_rss(‘wpurl’) ?>/xmlrpc.php” />
    <api name=”MetaWeblog” blogID=”1″ preferred=”false” apiLink=”<?php bloginfo_rss(‘wpurl’) ?>/xmlrpc.php” />
    <api name=”Blogger” blogID=”1″ preferred=”false” apiLink=”<?php bloginfo_rss(‘wpurl’) ?>/xmlrpc.php” />
    <api name=”Atom” blogID=”” preferred=”false” apiLink=”<?php echo apply_filters(‘atom_service_url’, (get_bloginfo(‘url’).”/wp-app.php/service”))?>” />

    I just left the WordPress line.
    And that’s working !


    JuMi you are the man!! It worked for me!

    Thanks a ton – I’ve been waiting so long for this to work.


    hmm JuMi’s fix isn’t working for me either
    no utf errors.. xmlrpc.php is fine
    everything goes as it should but the app keeps saying

    “we could not find the XML-RPC service for your blog. Please check your network connection and try again.”

    the blog is here: http://blog.punchdouble.com



    any development on this? i just got an iphone 3g, got wordpress application, i have 2.5.1 (i have to because my school runs the php for it), but i get the xml-rpc error. i tried everything suggested to no avail! i really got the iphone to be able to remotely take pictures and post while im on the go!! any help would be great

    Joseph Scott


    A number of fixes have gone into the app, hopefully a new version will be available at the store soon.

    I was also getting the XML-RPC error message, i got it working by inserting this link: <link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.YOURDOMAIN.com/xmlrpc.php?rsd" />. It is outputted by the <?php wp_head(); ?> in header.php.

    Not sure if this will work for anyone else, however seemed worth a shot telling everyone about it as some of you were getting positive results when changing themes.

    Joseph Scott



    Did you not have the edituri line in the HTML output of your blog already? Did you remove the wp_head() call in your theme? I recommend against removing the wp_head() call, many XML-RPC clients depend on the edituri line.

Viewing 15 replies - 31 through 45 (of 60 total)
  • The topic ‘Iphone app not connecting’ is closed to new replies.