Support » Fixing WordPress » Iphone app not connecting

  • I downloaded the iPhone app. Tried to run it but had to upgrade blog.

    Did so, and blog is running fine, but when i add the blog then hit save i get the spinning dial thing, then goes back to main screen and crashes.

    Then when i open the app, it stays on the spinning dial and nothing happens. No error messages.

    I tried with wrong passwords and urls and it notifies me those are not correct.

    Any ideas?

    Next step would be to install a new wordpress on my server, and then import the old database and related files manually.


Viewing 15 replies - 16 through 30 (of 60 total)
  • I tried disabling my themes and plugins but it still didn’t work.

    I emailed support from the iPhone app webpage (, and worked with someone there. He says it looks like it’s probably a mod_security or other type of Apache settings issue.

    I’ve forwarded it to my server host, so I guess if whatever he does works I’ll report back here.

    Restoring my theme from modmat to the default doesn’t resolve the issue, but I’m pretty sure it’s not the iphone app. It’s likely a misconfiguration of something on my side. I am unable to use the XMLRPC interface with other applications (non-iphone) as well so it is likely something local. I am, however, able to use the XMLRPC interface for a movable type blog on the same host under the same domain/directory structure.
    Trying to publish a google document to the wordpress xmlrpc access logs appear to be normal: - - [06/Aug/2008:08:43:30 -0500] "POST /blah/wordpress/xmlrpc.php?rnd1529036643=1790381435 HTTP/1.0" 200 182

    but I get an error that claims an “unexpected response”. I’ll keep chipping away at it, if anyone sees anything blatantly obvious that I’ve missed please feel free to point it out =)


    Im having the same exact problem with only one of my self-hosted blogs. My other blog (which is hosted on the same server) works fine. The only difference between the two is the wordpress version. The blog that works with the iPhone app is running on WP 2.5.1, while the non-working blog is on the latest 2.6.

    Clearly can’t be anything with apache on my end…

    I SO can’t wait to start blogging with this app, can’t wait to get this solved!

    Update: Sorry, forgot to add that I also messed around a bit last night. I followed the new directions added to the FAQ page on regarding the XML-RPC stuff. I tried loading the URL located in the RSD meta tag per the instructions – It takes like 20 seconds for it to load on my 2.6 install, while it loads instantly on my 2.5.1 install. So perhaps the iPhone app is timing out before the page is returned?

    I tried a couple more things without success:

    1) disabled all plugins
    2) changed to default theme

    No go. I keep checking this thread with my fingers crossed 🙂

    I also disabled all plugins and changed back to the default theme to simplify troubleshooting, I then went through the FAQ pages to check the RSD and all comes out as expected. At this point I may install a fresh test version of WP and see if that works. My only potentially relevant clue is an error in my log file:

    [Tue Aug 05 20:34:24 2008] [error] [client x.x.x.x] File does not exist: /services/www/

    Where the at the end should not be there.

    I’d much rather stick with WP than move back to Movable Type.


    We’ve had a few bug reports on blogs not setting up correctly. We’re still trying to pin down the exact cause, one item that still might be suspect is language. Any of you using a non-English setting?

    Mine is English.

    English for me as well.

    English multiple blogs hosted on same server, all 2.6. Last version worked fine for my main blog and others. After update main blog gets xmlrpc error while others are fine.

    Went in and tested the RDS and all good there. Removed some password protected dir’s.

    Thinking something in the update messed it up.

    Still a great app and I bet this will get figured out.

    @josephscott: Mine is English.

    My fiance and I worked on the server to try and figure out the problems. We found that it takes about 3 minutes for the xmlrpc.php?rsd file to load; it also doesn’t appear in the apache access log until then. The app must time out before it pulls up the page. If I pull up the xmlrpc page, it pulls up immediately and says “XML-RPC server accepts POST requests only” like the iPhone app FAQ says.

    mod_security is not installed, so that’s not the problem.

    Server info:
    Apache v2.0.52 – mod_security not installed
    mysql v5.0.51
    php v4.4.7

    Here’s everything we did to try to speed up the loading of the file:
    – Restarted both apache and mysql
    – Checked and optimized all mysql tables
    – Recompiled php with explicitly specifying the inclusion of xmlrpc support

    We’ve googled countless queries to try and find a workaround, but to no avail. If anyone has any other suggestions, we’ll try them.

    Until then, I’m using WPhone.

    If you are up to it you can help debug by using the iPhone SDK, grabbing the source code to the app and trying it out on the iPhone simulator (which comes with the SDK). I then use HTTP Scoop to watch the requests that the simulator makes to see where exactly it’s failing and what the error is in the SDK console.

    There are a couple of different common failure points that I’ve been observing with problem blogs, and we are still trying to pin down what exactly the error is and how to best fix it.

    The SDK requires Leopard. I’m running 10.4.11. Yeah, I know – I need to upgrade! 🙂

    Joseph – can I just grab the traffic for you from the server side? I can quickly and easily do a tcpdump/tcpflow and get you the output.

    Note however that I have already done this, and there’s nothing going on that I see awry. I see the initial request for the xmlrpc.php page come in from the iPhone, but no response from the server. I have a hunch that the xmlrpc.php page just takes too long to load (like Karen said it takes like 3 minutes for me as well via my browser on my MacBook), and the iPhone app times out in waiting.

    Also note that my second blog (which I can add to my iPhone) is running 2.5.1 and the xmlrpc.php page loads instantly in the browser on my Mac.


    Is there any way to get the previous version?
    It worked fine for me, but the new one is getting the xmlrpc error.

    I had the WP app installed on my iPhone 1st gen 2.0 firmware and everything worked fine on both mine and my associates websites on different domains. Last night I upgraded to 2.0.1 and have been getting the same xmlrpc error for both domains. Later tonight or tomorrow I’m going to try to restore the phone back to 2.0 and see if that resolves the issue for me, all other advice and help/FAQ’s I’ve read haven’t resolved it, and the phone’s firmware the only thing that has changed. We are using WP 2.6 on both domains.

Viewing 15 replies - 16 through 30 (of 60 total)
  • The topic ‘Iphone app not connecting’ is closed to new replies.