Support » How-To and Troubleshooting » Iphone app not connecting

Iphone app not connecting

  • I downloaded the iPhone app. Tried to run it but had to upgrade blog.

    Did so, and blog is running fine, but when i add the blog then hit save i get the spinning dial thing, then goes back to main screen and crashes.

    Then when i open the app, it stays on the spinning dial and nothing happens. No error messages.

    I tried with wrong passwords and urls and it notifies me those are not correct.

    Any ideas?

    Next step would be to install a new wordpress on my server, and then import the old database and related files manually.


Viewing 15 replies - 1 through 15 (of 60 total)
  • I have the exact same problem. But a clean install doesn’t seem to do the trick. I wiped my WordPress install completely from the server and installed a clean version of 2.6. I uninstalled the iPhone app and re-installed it as well. XML-RPC is enabled via the Wp-admin. Still no luck.

    Ok, think we will just have to wait for an update.

    Not sure what else to try, if you tried a full wipe and that didn’t work i am reluctant to. As the blog itself is working fine.

    Ok digisam,
    I went and got a new 3G iPhone this morning (I was on a 2G iPhone running 2.0 software). Then I re-installed all my applications, including wordpress. I get the Exact same problem. Add a blog correctly > Crash > Restart the app and I get the spinning progress wheel next to the blog name. I let it go for about 4 hours with no luck.

    I’m not sure what to do, other than be disappointed and move on. I hope someone has an answer soon.

    I’m also having the same problem. Updated blog working fine, forever spinning iPhone app. Have tried deleting and re-installing iPhone app, but am also reluctant to do another re-install of WordPress.

    Anyone have any ideas?

    You might want to try and disable your plugins and see if it works. I did that and it solved my problem (I couldn’t add my blog in the iphone app).

    For me the offending plugin was the AMM – Amazon Media Management Extension (ver1.5).


    Fixed it.

    When i upgraded my categories were lost. Following this helpful guide:
    http://blog.cumps.be/wordpress-26-upgrade-fix-missing-categories/ gave me my categories back.

    And then i tried it and bam, straight in

    Happy Sam 🙂

    …spoke too soon

    i can get into it but when i choose a category for a new post, the program crashes

    Ho hum, not sure what else to try, must have something to do with the categories, was a bit confusing. Ended up removing my Link Categories and adding them again.

    in phpmyadmin i had some rogue category rows in the wp_term_taxonomy table

    I removed these (had no other ideas to try)

    And then i tried the iphone, it crashed again when i tried to view the categories “drop down”

    I removed the blog from the iphone and added it again, and success, it worked (for now)

    Yay!! it’s working for me too. I followed the helpful guide and after a delete of the blog from the phone and a re-install, I’m up and running (so far!). Thanks for finding the link!


    I just installed the latest version of WP in my 3G iPhone, but I can’t add my Blog: blogs.strat-cons.com.

    There’s this message which keeps appearing: “We could not find the XML-RPC service for your blog…”

    I’m running with 2.6 and the XLM RPC switch is ON

    What does this mean? How can I solve it?

    Tnaks in advance.

    I’m seeing the same xmlrpc error but only when I prepend http:// to the url. If I do not prepend it I get the same vague error 5 that I saw before. Checking the apache logs, it appears that the folder that the software is requesting is incorrect for some reason. This is a new install of WP with the newest version of the app as of this writing. I’m still digging, at least I think I know what is causing the error (wrong path). Has anyone else seen this?


    @buraglio – I am having the exact same problem as you and xtello. My XMLRPC file is right there (my site is my blog) but the WordPress app simply will not find it.


    I am having the same problem. I wish we could fix it.

    I seem to have the exact same problem.
    In my case, I am running 3 blogs from the same domain name (one under www, 2 under subdomains). The one blog that is failing is the blog written mainly in French (or non english). I am wondering if this could be the cause.

    I am seeing the exact same errors. I’ll try all tricks suggested on the page.

    I wish we could really debug iPhones app…

    Actually.. I just solved it!!!

    It was the theme I used for my site (Called Velle Elle). I have restored the theme to the default one and.. VOILA! Working like a charm!

Viewing 15 replies - 1 through 15 (of 60 total)
  • The topic ‘Iphone app not connecting’ is closed to new replies.