Support » Plugin: Mobile Smart » iPad shows mobile theme when not enabled

  • The iPad shows the mobile theme and not the desktop theme even when not enabled. Is there a fix for this? How can I get only the iPhone/mobile to show the mobile theme?

    And also is custom menu only available in the paid version? The free version is displaying a list of pages in alphabetical order and not how I have it.

    https://wordpress.org/plugins/mobile-smart/

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author dolby_uk

    (@dolby_uk)

    What settings do you have currently?

    Also, can you check that your theme isn’t responsive, which means that it would adapt to the device it’s being displayed on. So if it’s responsive and shown on a tablet, quite oftehn they reduce the width and change the layout / menu.

    Custom menu support is only available in the pro version. The free version may be displaying a list of pages because the theme location name for your menu doesn’t match between your mobile and desktop theme. You should ensure that they have the same theme location name used for register_nav_menu() and wp_nav_menu() – you may need a developer to do this if you’re not comfortable with looking at the code yourself.

    The pro plugin helps manage this by adding a ‘mapping’ section where you can supply the theme location name of the mobile theme in order to map the desktop theme to the mobile theme.

    I had the same issue – iPad was showing mobile even after toggling the show mobile theme for tablets on and off.

    Dug deeper and it appears the new mdetect.php module has a bug. It’s using a variable before it’s initialized.

    I submitted a patch to the main project and yours as well:

    https://github.com/dansmart/mobile-smart/pull/1

    https://github.com/ahand/mobileesp/pull/15

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘iPad shows mobile theme when not enabled’ is closed to new replies.