User Access Manager
[resolved] IP-based login dosn't work? (3 posts)

  1. mhartvig
    Posted 1 year ago #

    Hello everyone!

    After moving to a new host, i can no-longer use the IP-based login featue of this plugin. Everything worked just fine on my old host (using litespeed webserver). The new host uses apache with varnish enabled.

    I have tried to make a clean install on another apache based host, but havent got any luck.

    Have tried all kinds of settings and .htaccess additions to disable caching. Nothing seems to work. The website behaves just like the ip-address arent correctly set up (works on the litespeed, not the apache).


  2. GM_Alex
    Plugin Author

    Posted 1 year ago #

    Varnish will cache the whole site, so the page is not dynamic anymore. Try to disable varnish and test if it then works. If yes varnish it the problem.

  3. mhartvig
    Posted 1 year ago #

    In case others have the same issue: Problem is now solved.

    - Varnish was disabled on the host, but for some reason, the $_SERVER[“REMOTE_ADDR”] variable was returning the server proxy IP rather than the client IP (due to varnish operating as a "a proxy server").

    All clients $_SERVER[“REMOTE_ADDR” was therefore in fact returning the wrong server-ip. Short-term sollution: "X forwarded for" in $_SERVER is in fact returning the correct value, but i wouldnt reccomend using that in the plugin by anyone, as it's easily spoofed client-side:)

    My host is currently working on a sollution (as it is in fact a configuration error on their part).

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • User Access Manager
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic