Support » Plugins and Hacks » [Resolved] IP addresses not showing (being added to Db) in version 1.1.9

[Resolved] IP addresses not showing (being added to Db) in version 1.1.9

  • I’m having the same problem that was reported earlier.
    I can onlt see – (null) values in the Db

    I’m on the latest 1.1.9 version and it’s happening on more than one install.

    I have uninstalled Stream, checked to see that the Db was erased, reinstalled Stream – but got the same results.

    Wordpress 3.8.1 (single site)
    PHP version: 5.3.27
    MySQL running on: Localhost
    This is a public (published) site
    MySQL version: 5.5.30
    Server type: Linux
    Info about Server (from phpinfo.php)

    <address>Apache/2.0.64 (Unix) mod_ssl/2.0.64 OpenSSL/0.9.7a mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/ mod_fcgid/2.3.6 Sun-ONE-ASP/4.0.2 Server at cbbtest.com Port

    Apache/2.0.64 (Unix) mod_ssl/2.0.64 OpenSSL/0.9.7a mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/ mod_fcgid/2.3.6 Sun-ONE-ASP/4.0.2

    I was particularly concerned that IP addresses are not showing after I discovered that there had been multiple attempts to login using “Admin” (a non existent user) and I wanted to know WHO was attempting this.



Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Author Frankie Jarrett


    Hi mjezard!

    Are you sure that every entry has a NULL value for the IP, or is it only these failed login attempts for the “Admin” user?

    Also, I highly recommend you combat any brute force login attacks on your site with a plugin like Limit Login Attempts, or similar. Stream is a great way to detect and give warning to these kinds of malicious activities.

    I am certain that all entries in the _stream table have NULL entries.

    I have a test site that I’m “playing with” as well – same issue – same hosting – That I could give you access to if you’d like to take a look. It also had a bunch of access attempts.

    I agree that Stream (if I can get it working) will be a great tool to detect and warn against unauthorized access. I’ll probably be putting Wordfence on the site as well.

    I’m not sure how to add attachments here otherwise I would have attached the .sql dump I just created.

    Plugin Author Frankie Jarrett


    Hi mjezard,

    So just to clarify, are you saying that every column on every record in the stream table has NULL values? Or is it just the IP column that is showing NULL values?

    Just the ip column.

    Here’s a couple of lines from an SQL Dump:

    insert into base_stream(ID,site_id,object_id,author,summary,visibility,parent,type,created,ip) values (339,1,NULL,3,’\”engines\” setting was updated’,’publish’,0,’stream’,’2014-02-12 15:45:09′,NULL);
    insert into base_stream(ID,site_id,object_id,author,summary,visibility,parent,type,created,ip) values (340,1,1259,3,’\”Search\” page updated’,’publish’,0,’stream’,’2014-02-12 15:47:39′,NULL);
    insert into base_stream(ID,site_id,object_id,author,summary,visibility,parent,type,created,ip) values (341,1,3,3,’michael53 logged in’,’publish’,0,’stream’,’2014-02-13 16:17:04′,NULL);
    insert into base_stream(ID,site_id,object_id,author,summary,visibility,parent,type,created,ip) values (342,1,NULL,3,’Updated plugin: Stream to 1.2′,’publish’,0,’stream’,’2014-02-13 16:18:26′,NULL);

    Anything further on this IP address problem?

    I now have Stream installed on five sites and they all have the same problem. All running latest and greatest. The one thing they all have in common is the ISP (LunarPages)

    As I said earlier, I could give you access to a site for faultfinding, If you are interested you’ll have to let me know via e-mail or something (don’t know how to deal with private communications here)


    I see you have a contact form online. Let me know and I’ll send info

    Plugin Author Shady Sharaf


    Hi mjezard,

    Please do send a valid access to one of your sites at shady+plugins at{our website domain}, so i’d have a look and try to guess the cause of the issue.


    Ummm…. Couldn’t find “{our website domain}” so I sent to your personal e-mail (I hope).

    Please let me know if you got it.

    Plugin Author Shady Sharaf


    Thank you for reporting this, I’ve confirmed that the issue is caused of a PHP bug (https://bugs.php.net/bug.php?id=49184) and reported it at https://github.com/x-team/wp-stream/issues/254 , and a fix should be released in the next update.

    Thank you for your support and for helping us make this plugin better!


    I’m assuming you mean the next update of Stream (using the workaround) and not the next update of PHP.

    Otherwise, I love the Plugin.


    Plugin Author Shady Sharaf


    Yes, the next update of Stream 🙂

    Plugin Author Frankie Jarrett


    Just to clarify, I’ve just released v1.2.2 and the fix is not in this release. We are still working to resolve this PHP bug. I will keep you posted on this thread when we do release an update that fixes it.

    Plugin Author Frankie Jarrett


    OK mjezard, we’ve just released v1.2.3 of the plugin which should resolve the issue you were having with IP addresses. Please update and test it out. Thanks!

    Sorry to report – no change 🙁
    I installed on the machine you have access to – didn’t change.

    I deactivated and activated after I saw that nothing had changed, but that didn’t do anything either.

    Did Shady give you access as well?


    I checked again and it seems that the IP addresses are now being logged. For some reason it takes a little while to “take”. Not sure if it’s next login or what. In any event the problem is solved.

    I checked on more than one site, all OK

    Thanks again guys.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘[Resolved] IP addresses not showing (being added to Db) in version 1.1.9’ is closed to new replies.