WordPress.org

Support

Support » How-To and Troubleshooting » IO Error still causing trouble

IO Error still causing trouble

  • So, I’ve read all the posts regarding the IO Error when uploading images. I could really use a hand in trying to determine what’s going on.

    I’ve gone through this sticky post:
    http://wordpress.org/support/topic/25-imagemedia-uploader-problems

    Cleared cache, restarted browsers many times. I’m using Mac Snow Leopard and the error shows up in both Safari and Firefox.

    My WP install is not using any custom file paths in Media settings. All files are definitely uploaded properly, as it’s synched to my local environment.

    It’s not my Flash version; I updated that. Plus, the error does not occur in a localhost environment in the very same browsers; it does occur on my live server (dedicated server, I can access php.ini and httpd configs.)

    Other members of my team also receive this error, on their own computers, running both Windows and Mac. It’s got to be something on the server.

    I’ve tried adding in the mod_security settings, both in my apache config and in .htaccess, but still no luck. I tried <IfModule mod_security.c> <IfModule security_mod> and <IfModule security2_mod>.

    The issue:
    1. Upload an image
    2. IO Error given, progress bar hangs up on “Crunching..” or doesn’t make any progress (I see no patterns here)

    The file is actually uploaded and placed within the correct upload directory. But the IO Error just sits there, and I’m sure my client (site editor) will not like that.

    So, one workaround idea is to simply disable the flash uploader. But when I “Use browser uploader instead”, there’s another problem: it uploads the file repeatedly as if in an endless loop. I doubt this is a WP bug, but it could be related to my IO Error issue above. There’s no error message, but when I visit the Media section after using the browser uploader, the file is listed at least 15 times.

    I think these issues could be related.

    Nothing related shows up in my server’s error logs.

    Does anyone have any ideas as to what else I can try? Again, I’ve gone through the IO Error posts and tried everything, but to no avail.

    * Other modules that may be causing trouble?
    * Issues with /tmp directory?
    * Anything to do with sessions?

Viewing 5 replies - 1 through 5 (of 5 total)
Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘IO Error still causing trouble’ is closed to new replies.
Skip to toolbar