Support » Plugin: Mail Bank - #1 Mail SMTP Plugin for WordPress » involid argument sidebar-menu.php on line 88

  • Resolved romainb

    (@romainb)


    Hello,

    After having updated to last version of wp mail bank (2.0.15) on wordpress 3.9.15 (I can’t upgrade to v4 due to theme issue).
    I receive a strange error message on top of the wordpress admin page:
    “Warning: Invalid argument supplied for foreach() in /home/boostaeroi/www/wp-content/plugins/wp-mail-bank/lib/sidebar-menu.php on line 88”
    I tried to uninstall / reinstall plugin: Same issue.

    If I try to open the settings of the plugin I get “you do not have sufficient permissions to access this page”
    Warning: Invalid argument supplied for foreach() in /home/boostaeroi/www/wp-content/plugins/wp-mail-bank/lib/sidebar-menu.php on line 88
    You do not have sufficient permissions to access this page.

    I verified the files rights through FTP, and same as all other plugins.

    I have iThemes security running with very basic options that I verified but nothing impacting files access.
    Tried to remove .htaccess no impact.

    I noticed that on the previous version, Version 2.0.12 I cannot access the settings page of the plugin, getting
    “You do not have sufficient permissions to access this page.” Error, but the plugin is working.

    Some test of regression, tried previous plugin version:

    Version 1.46 working, no issue.
    1.47 working, no issue.
    2.0.6 ko
    2.0.10 ko
    2.0.0 ko

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Contributor The WP Empire

    (@wordpress-empire)

    Hi,

    Please delete and re-install the latest plugin.

    You will have this fixed.

    Thanks

    Support Team
    WP Mail Bank

    Thread Starter romainb

    (@romainb)

    Done.
    Uninstalled,
    installed new one (Version 2.0.17),
    activated: Still same issue.

    Thread Starter romainb

    (@romainb)

    For info,
    I asked support to the “support team” who proposed to investigate on the issue by taking control of WordPress + FTP.
    I’m just a little bit concern before giving administrator rights on my website content.
    could you confirm me they are trustworthy ?

    Received: from [27.255.164.153] (port=54022 helo=SupportDept)
    	by vivaan.tech-banker.com with esmtpsa (TLSv1.2:ECDHE-RSA-AES256-SHA384:256)
    	(Exim 4.87)
    	(envelope-from <support@tech-banker.com>)
    
    Plugin Contributor The WP Empire

    (@wordpress-empire)

    Hi,

    This problem is because you have updated from a very old version of Mail Bank.

    You may provide the requested information to our support team if you wish to and they can sort out the issue for you. But this entirely depends upon you! We don’t force that ever.

    But if you are hesitant, we can let you know the steps if you are a little tech savy!

    1) Login to your phpmyadmin console and then look for table wp_options.
    2) Search option “mail-bank-version-number” in option_name and then delete this option.
    3) Delete any tables if they starts with wp_mail_bank.
    4) Uninstall the plugin and then re-install the plugin.

    These steps should fix the problem completely.

    Thanks

    Support Team
    WP Mail Bank

    Thread Starter romainb

    (@romainb)

    Thanks,
    I would have provided this info if I could have some proof of identity of the support πŸ˜‰ it’s the website of my company…

    Thanks for your help.

    I’ve connected to phpmysql, looking for what you told an found found it in the “option” table by looking for “mail%version%” in a search query in all databases.

    I found a table called XYZ_mail_bank (XYZ beeing the random security number in front of all my DB tables) with one line (the config of the plug in), I will delete it.

    • This reply was modified 4 years, 7 months ago by romainb.
    Thread Starter romainb

    (@romainb)

    :-C player try again :-C
    still
    "Warning: Invalid argument supplied for foreach() in /home/boostaeroi/www/wp-content/plugins/wp-mail-bank/lib/sidebar-menu.php on line 88"

    verified in database, the “mail-bank-version-number 2.0.3” is back πŸ˜‰
    but no more mail_bank table (maybe it will be created when the plugin will work again).

    Plugin Contributor The WP Empire

    (@wordpress-empire)

    Hi,

    Follow these steps :

    1) Please completely delete the plugin from your WordPress site.
    2) Go to your phpmyadmin database and look for the table XYZ_options(XYZ being the random security number in front of all my DB tables).
    3) Search β€œ%mail-bank-version-number%” in option_name and then delete this option.
    4) Delete any tables if they starts with XYZ_mail_bank(XYZ being the random security number in front of all my DB tables).
    5) Re-install the Plugin

    These should fix the problem.

    Please let us know if you still face issues.

    Thanks

    Support Team
    WP Mail Bank

    Thread Starter romainb

    (@romainb)

    Sorry but this is what I have done yesterday, without result.

    only difference is that I did not uninstalled the plugin before removing database data, I’ve done it afterward.

    I think that the issue is not there…

    Plugin Contributor The WP Empire

    (@wordpress-empire)

    Hi,

    Yes, please uninstall the plugin before removing database.

    This is the issue and this will be fixed if you follow the steps mentioned 1-5.

    Thanks

    Support Team
    WP Mail Bank

    Thread Starter romainb

    (@romainb)

    no,
    don’t work.

    Thread Starter romainb

    (@romainb)

    SOLVED issue!

    problem was linked to the database configuration,
    wordpress database account was not configured as “administrator” of the DB but only as “read/write”.

    And the upgrade of the mail bank plugin should had required that the service account was “administrator” to be upgraded correctly.

    Applied Support instructions, after having changed accounts rights: uninstalled plugin, manually deleted database table and option of mail bank version in the “options” table, installed plugin, activated, configured: working !

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘involid argument sidebar-menu.php on line 88’ is closed to new replies.