Support » Plugin: WP Proposals » Invoice URL doesn’t save

  • Resolved ralphonz

    (@ralphonz)


    Hi there,

    When I add an invoice URL and then click Update or Publish, the URL isn’t saved.

    The same thing happens if I use quick edit on the “All proposals” list page. If i enter an invoice URL and click update the field returns empty.

    Invoice URL’s are NOT disabled in the settings…

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author WP Codeus

    (@wpcodeus)

    Hello @ralphonz,

    We have just checked our staging site and are not able to duplicate the issue nor other support tickets from users.

    Please ensure you’re using the latest version of WP Proposals and WordPress.

    When you add an Invoice URL you must hit the ‘Add’ button or enter on your keyboard to apply your URL.

    To troubleshoot you can open up the console log on your browser to see if you’re getting an error messages that might be caused by a 3rd party plugin.

    You can also temporarily disable plugins on your install to see if you can pinpoint the issue.

    Thread Starter ralphonz

    (@ralphonz)

    Hi there,

    Supper quick response!

    I can confirm I’m using the latest versions and clicking the right buttons etc.

    There is no error message displayed. I will check php MyAdmin to see if the value is actually being saved to the database…

    Thread Starter ralphonz

    (@ralphonz)

    Hi there,

    I did some further testing and I’m able to add fake invoice URL’s such as https”://fakeinvoice.com but I’m not able to add the URL from my book keeping software – it just doesn’t get saved. Perhaps it’s too long and reaching some sort of character limit?

    I can use tiny URL for now but it would be nice to be able to just paste the original link in.

    Thread Starter ralphonz

    (@ralphonz)

    The URL I’m trying to use is 255 characters. If I shorten it it will save with the proposal, but then obviously the link is broken!

    Plugin Author WP Codeus

    (@wpcodeus)

    Hello @ralphonz,

    WP Proposals uses the default taxonomy functionality for the Invoice URL. I do not think character count is your issue, but your book keeping software could have a character included in the text that is triggering the sanitization to delete the data for security reason.

    Unfortunately, this is not something we are able to changes as it is the default functionality of WordPress.

    I recommend using a shortener or URL redirect if you wish to use this feature with your current booking system.

    Thread Starter ralphonz

    (@ralphonz)

    Hey there,

    Just wanted to say thanks for the quick support.

    I’ve checked and it’s not special characters in the URL causing the issue, definitely just the length of it.

    I can find no information for a max length for terms in any wordpress documentation but I guess it could be server-related, something to do with MySQL settings (the site uses shared hosting).

    Anyway, thanks again for the support and the plugin!

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.