Support » Fixing WordPress » Invisible html for background image appearing at bottom of posts/pages

  • I’ve noticed that html is showing up at the bottom of byrdnick.com’s posts and pages. The html is not visible from the front end or from the visual editor. It is only visible from the text editor. When I delete is and update the post, it comes back.

    Here’s an example of the html that keeps showing up:

    <span style="border-top-left-radius: 2px; border-top-right-radius: 2px; border-bottom-right-radius: 2px; border-bottom-left-radius: 2px; text-indent: 20px; width: auto; padding: 0px 4px 0px 0px; text-align: center; font-style: normal; font-variant-caps: normal; font-weight: bold; font-size: 11px; line-height: 20px; font-family: 'Helvetica Neue', Helvetica, sans-serif; color: #ffffff; background-image: url(data:image/svg+xml; base64,phn2zyb4bwxucz0iahr0cdovl3d3dy53my5vcmcvmjawmc9zdmciighlawdodd0imzbwecigd2lkdgg9ijmwchgiihzpzxdcb3g9ii0xic0xidmxidmxij48zz48cgf0acbkpsjnmjkundq5lde0ljy2mibdmjkundq5ldiyljcymiaymi44njgsmjkumju2ide0ljc1ldi5lji1nibdni42mzismjkumju2idaumduxldiyljcymiawlja1mswxnc42njigqzaumduxldyunjaxidyunjmyldaumdy3ide0ljc1ldaumdy3iemymi44njgsmc4wnjcgmjkundq5ldyunjaxidi5ljq0oswxnc42njiiigzpbgw9iinmzmyiihn0cm9rzt0ii2zmziigc3ryb2tllxdpzhropsixij48l3bhdgg+phbhdgggzd0itte0ljczmywxljy4nibdny41mtysms42odygms42njusny40otugms42njusmtqunjyyiemxljy2nswymc4xntkgns4xmdksmjquodu0idkuotcsmjyunzq0iem5ljg1niwyns43mtggos43ntmsmjqumtqzidewljaxniwymy4wmjigqzewlji1mywymi4wmsaxms41ndgsmtyuntcyidexlju0ocwxni41nzigqzexlju0ocwxni41nzigmteumtu3lde1ljc5nsaxms4xntcsmtqunjq2iemxms4xntcsmtiuodqyideyljixmswxms40otugmtmuntiyldexljq5nsbdmtqunjm3ldexljq5nsaxns4xnzusmtiumzi2ide1lje3nswxmy4zmjmgqze1lje3nswxnc40mzygmtqundyylde2ljegmtqumdkzlde3ljy0mybdmtmunzg1lde4ljkznsaxnc43ndusmtkuotg4ide2ljayocwxos45odggqze4ljm1mswxos45odggmjaumtm2lde3lju1niaymc4xmzysmtqumdq2iemymc4xmzysmtauotm5ide3ljg4ocw4ljc2nyaxnc42nzgsoc43njcgqzewljk1osw4ljc2nya4ljc3nywxms41mzygoc43nzcsmtqumzk4iem4ljc3nywxns41mtmgos4ymswxni43mdkgos43ndksmtcumzu5iem5ljg1niwxny40odggos44nzismtcunia5ljg0lde3ljczmsbdos43ndesmtgumtqxidkuntismtkumdizidkundc3lde5ljiwmybdos40miwxos40nca5lji4ocwxos40otegos4wncwxos4znzygqzcunda4lde4ljyymia2ljm4nywxni4yntigni4zodcsmtqumzq5iem2ljm4nywxmc4yntygos4zodmsni40otcgmtuumdiyldyundk3iemxos41ntusni40otcgmjmumdc4ldkunza1idizlja3ocwxmy45otegqzizlja3ocwxoc40njmgmjaumjm5ldiylja2miaxni4yotcsmjiumdyyiemxnc45nzmsmjiumdyyidezljcyocwyms4znzkgmtmumzayldiwlju3mibdmtmumzayldiwlju3miaxmi42ndcsmjmumdugmtiundg4ldizljy1nybdmtiumtkzldi0ljc4ncaxms4zotysmjyumtk2idewljg2mywyny4wntggqzeylja4niwyny40mzqgmtmumzg2ldi3ljyznyaxnc43mzmsmjcunjm3iemyms45nswyny42mzcgmjcuodaxldixljgyocayny44mdesmtqunjyyiemyny44mdesny40otugmjeuotusms42odygmtqunzmzldeunjg2iibmawxspsijymqwodfjij48l3bhdgg+pc9npjwvc3znpg==); background-size: 14px 14px; background-color: #bd081c; position: absolute; opacity: 1; z-index: 8675309; display: none; cursor: pointer; border: none; -webkit-font-smoothing: antialiased; background-position: 3px 50%; background-repeat: no-repeat no-repeat;">Save</span><span style="border-top-left-radius: 2px; border-top-right-radius: 2px; border-bottom-right-radius: 2px; border-bottom-left-radius: 2px; text-indent: 20px; width: auto; padding: 0px 4px 0px 0px; text-align: center; font-style: normal; font-variant-caps: normal; font-weight: bold; font-size: 11px; line-height: 20px; font-family: 'Helvetica Neue', Helvetica, sans-serif; color: #ffffff; background-image: url(data:image/svg+xml; base64,phn2zyb4bwxucz0iahr0cdovl3d3dy53my5vcmcvmjawmc9zdmciighlawdodd0imzbwecigd2lkdgg9ijmwchgiihzpzxdcb3g9ii0xic0xidmxidmxij48zz48cgf0acbkpsjnmjkundq5lde0ljy2mibdmjkundq5ldiyljcymiaymi44njgsmjkumju2ide0ljc1ldi5lji1nibdni42mzismjkumju2idaumduxldiyljcymiawlja1mswxnc42njigqzaumduxldyunjaxidyunjmyldaumdy3ide0ljc1ldaumdy3iemymi44njgsmc4wnjcgmjkundq5ldyunjaxidi5ljq0oswxnc42njiiigzpbgw9iinmzmyiihn0cm9rzt0ii2zmziigc3ryb2tllxdpzhropsixij48l3bhdgg+phbhdgggzd0itte0ljczmywxljy4nibdny41mtysms42odygms42njusny40otugms42njusmtqunjyyiemxljy2nswymc4xntkgns4xmdksmjquodu0idkuotcsmjyunzq0iem5ljg1niwyns43mtggos43ntmsmjqumtqzidewljaxniwymy4wmjigqzewlji1mywymi4wmsaxms41ndgsmtyuntcyidexlju0ocwxni41nzigqzexlju0ocwxni41nzigmteumtu3lde1ljc5nsaxms4xntcsmtqunjq2iemxms4xntcsmtiuodqyideyljixmswxms40otugmtmuntiyldexljq5nsbdmtqunjm3ldexljq5nsaxns4xnzusmtiumzi2ide1lje3nswxmy4zmjmgqze1lje3nswxnc40mzygmtqundyylde2ljegmtqumdkzlde3ljy0mybdmtmunzg1lde4ljkznsaxnc43ndusmtkuotg4ide2ljayocwxos45odggqze4ljm1mswxos45odggmjaumtm2lde3lju1niaymc4xmzysmtqumdq2iemymc4xmzysmtauotm5ide3ljg4ocw4ljc2nyaxnc42nzgsoc43njcgqzewljk1osw4ljc2nya4ljc3nywxms41mzygoc43nzcsmtqumzk4iem4ljc3nywxns41mtmgos4ymswxni43mdkgos43ndksmtcumzu5iem5ljg1niwxny40odggos44nzismtcunia5ljg0lde3ljczmsbdos43ndesmtgumtqxidkuntismtkumdizidkundc3lde5ljiwmybdos40miwxos40nca5lji4ocwxos40otegos4wncwxos4znzygqzcunda4lde4ljyymia2ljm4nywxni4yntigni4zodcsmtqumzq5iem2ljm4nywxmc4yntygos4zodmsni40otcgmtuumdiyldyundk3iemxos41ntusni40otcgmjmumdc4ldkunza1idizlja3ocwxmy45otegqzizlja3ocwxoc40njmgmjaumjm5ldiylja2miaxni4yotcsmjiumdyyiemxnc45nzmsmjiumdyyidezljcyocwyms4znzkgmtmumzayldiwlju3mibdmtmumzayldiwlju3miaxmi42ndcsmjmumdugmtiundg4ldizljy1nybdmtiumtkzldi0ljc4ncaxms4zotysmjyumtk2idewljg2mywyny4wntggqzeylja4niwyny40mzqgmtmumzg2ldi3ljyznyaxnc43mzmsmjcunjm3iemyms45nswyny42mzcgmjcuodaxldixljgyocayny44mdesmtqunjyyiemyny44mdesny40otugmjeuotusms42odygmtqunzmzldeunjg2iibmawxspsijymqwodfjij48l3bhdgg+pc9npjwvc3znpg==); background-size: 14px 14px; background-color: #bd081c; position: absolute; opacity: 1; z-index: 8675309; display: none; cursor: pointer; border: none; -webkit-font-smoothing: antialiased; background-position: 3px 50%; background-repeat: no-repeat no-repeat;">Save</span>

    I recently installed the following plugins and I wonder if it has to do with one of these:

    Autoptimize
    AMP
    Google Analytics Dashboard for WP (GADWP)
    WP Super Cache

    Thanks for anyone’s help in advance!

Viewing 15 replies - 1 through 15 (of 27 total)
  • Moderator Steven Stern

    (@sterndata)

    Support Team / Sword in the Darkness

    That is most likely an inlined-image from autoptimize. It speeds up your site to have the image included in the HTML source rather than setting it as another fetch.

    It is not indicative of being hacked.

    • This reply was modified 1 year, 9 months ago by  Steven Stern.

    same problem here. I have wp-amp and autoptimize also installed.

    this is what I am getting:

    <span style=”border-top-left-radius: 2px; border-top-right-radius: 2px; border-bottom-right-radius: 2px; border-bottom-left-radius: 2px; text-indent: 20px; width: auto; padding: 0px 4px 0px 0px; text-align: center; font-style: normal; font-variant-caps: normal; font-weight: bold; font-size: 11px; line-height: 20px; font-family: ‘Helvetica Neue’, Helvetica, sans-serif; color: #ffffff; background-image: url(data:image/svg+xml; base64,phn2zyb4bwxucz0iahr0cdovl3d3dy53my5vcmcvmjawmc9zdmciighlawdodd0imzbwecigd2lkdgg9ijmwchgiihzpzxdcb3g9ii0xic0xidmxidmxij48zz48cgf0acbkpsjnmjkundq5lde0ljy2mibdmjkundq5ldiyljcymiaymi44njgsmjkumju2ide0ljc1ldi5lji1nibdni42mzismjkumju2idaumduxldiyljcymiawlja1mswxnc42njigqzaumduxldyunjaxidyunjmyldaumdy3ide0ljc1ldaumdy3iemymi44njgsmc4wnjcgmjkundq5ldyunjaxidi5ljq0oswxnc42njiiigzpbgw9iinmzmyiihn0cm9rzt0ii2zmziigc3ryb2tllxdpzhropsixij48l3bhdgg+phbhdgggzd0itte0ljczmywxljy4nibdny41mtysms42odygms42njusny40otugms42njusmtqunjyyiemxljy2nswymc4xntkgns4xmdksmjquodu0idkuotcsmjyunzq0iem5ljg1niwyns43mtggos43ntmsmjqumtqzidewljaxniwymy4wmjigqzewlji1mywymi4wmsaxms41ndgsmtyuntcyidexlju0ocwxni41nzigqzexlju0ocwxni41nzigmteumtu3lde1ljc5nsaxms4xntcsmtqunjq2iemxms4xntcsmtiuodqyideyljixmswxms40otugmtmuntiyldexljq5nsbdmtqunjm3ldexljq5nsaxns4xnzusmtiumzi2ide1lje3nswxmy4zmjmgqze1lje3nswxnc40mzygmtqundyylde2ljegmtqumdkzlde3ljy0mybdmtmunzg1lde4ljkznsaxnc43ndusmtkuotg4ide2ljayocwxos45odggqze4ljm1mswxos45odggmjaumtm2lde3lju1niaymc4xmzysmtqumdq2iemymc4xmzysmtauotm5ide3ljg4ocw4ljc2nyaxnc42nzgsoc43njcgqzewljk1osw4ljc2nya4ljc3nywxms41mzygoc43nzcsmtqumzk4iem4ljc3nywxns41mtmgos4ymswxni43mdkgos43ndksmtcumzu5iem5ljg1niwxny40odggos44nzismtcunia5ljg0lde3ljczmsbdos43ndesmtgumtqxidkuntismtkumdizidkundc3lde5ljiwmybdos40miwxos40nca5lji4ocwxos40otegos4wncwxos4znzygqzcunda4lde4ljyymia2ljm4nywxni4yntigni4zodcsmtqumzq5iem2ljm4nywxmc4yntygos4zodmsni40otcgmtuumdiyldyundk3iemxos41ntusni40otcgmjmumdc4ldkunza1idizlja3ocwxmy45otegqzizlja3ocwxoc40njmgmjaumjm5ldiylja2miaxni4yotcsmjiumdyyiemxnc45nzmsmjiumdyyidezljcyocwyms4znzkgmtmumzayldiwlju3mibdmtmumzayldiwlju3miaxmi42ndcsmjmumdugmtiundg4ldizljy1nybdmtiumtkzldi0ljc4ncaxms4zotysmjyumtk2idewljg2mywyny4wntggqzeylja4niwyny40mzqgmtmumzg2ldi3ljyznyaxnc43mzmsmjcunjm3iemyms45nswyny42mzcgmjcuodaxldixljgyocayny44mdesmtqunjyyiemyny44mdesny40otugmjeuotusms42odygmtqunzmzldeunjg2iibmawxspsijymqwodfjij48l3bhdgg+pc9npjwvc3znpg==); background-size: 14px 14px; background-color: #bd081c; position: absolute; opacity: 1; z-index: 8675309; display: none; cursor: pointer; border: none; -webkit-font-smoothing: antialiased; background-position: 3px 50%; background-repeat: no-repeat no-repeat;”>Κράτα το</span>

    Pedro

    (@petredobrescu)

    Hello there. I’m facing a similar issue, but none of the plugins you mentioned is installed, which makes me think that it may be related to one of the computers used to add/edit content.

    @nick_byrd @valantis_c – have you managed to trace the source of this code added to the text editor?

    Thanks!

    Moderator Steven Stern

    (@sterndata)

    Support Team / Sword in the Darkness

    @valantis_c and @petredobrescu, please start a new forum post for your issue rather than jumping into an existing, old thread. Thanks.

    I’m having the exact same code injection issue on two client sites. Both WordPress sites were migrated from Blogger (one over a year ago, the other only a couple weeks ago). Neither site has the plugins @nick_byrd mentioned. The only common plugins between the two sites are:

    • Categories to Tags Converter Importer
    • Term Management Tools
    • Yoast SEO

    The are both on different Genesis Child Themes.

    @sterndata, it seems that all of us ( @valantis_c and @petredobrescu and myself) are experiencing the exact same problem that @nick_byrd posted about originally. Is it forum protocol for use to start new threads for the exact same problem (the injected code appears to be practically identical).

    • This reply was modified 1 year, 8 months ago by  fivejs.
    Moderator Steven Stern

    (@sterndata)

    Support Team / Sword in the Darkness

    @fivejs, please start a new forum post for your issue rather than jumping into an existing, old thread. Thanks.

    @nick_byrd, @petredobrescu, and @valantis_c, I believe I pinpointed the issue, at least for my clients. I was unable to duplicate the issue of the code injection on my end UNTIL I installed the Pinterest Safari extension (which BOTH of my clients were using, and BOTH were using Safari when editing & updating their WP posts). Once I installed the Safari extension, I was able to replicate the issue of the HTML injection of that code at the end of the posts.

    So the question might be for you guys, is this something you have in common? Are you using Safari when updating/creating/editing posts? If so, do you have the Safari Pinterest extension installed? Or do you have a Pinterest extensions installed in the browser you ARE using?

    Moderator Steven Stern

    (@sterndata)

    Support Team / Sword in the Darkness

    @fivejs: I’m pretty sure you got it. I recall a number of other threads where pinterest extensions do that.

    @fivejs: I do too 🙁 also editing with safari…

    @fivejs: I am editing in Safari with the Pinterest extension installed.

    That seems to support your hypothesis that the problem is Safari and/or the Pinterest extension.

    @petredobrescu: Are you posting/editing in Safari and/or with a Pinterest extension installed?

    Pedro

    (@petredobrescu)

    Hy all,

    Indeed the Pinterest extension was the issue in my case too, but this time it was in Chrome.

    Maybe it would be a good idea to raise a support issue with the Pinterest team or investigate it further with the WP Core team, as I assume this will affect many other WordPress users.

    @sterndata I’m sorry but I don’t understand why should we start a new thread when we are all facing exactly the same issue? Can you please detail this recommendation?

    Moderator Steven Stern

    (@sterndata)

    Support Team / Sword in the Darkness

    Pedro: It now seems it was the same problem. Generally, they are not.

    @nick_byrd, @petredobrescu, @fivejs and @valantis_c thank you for persisting in keeping posts to this thread. I was able to find the source of the same issue on my sites thanks to a search on a bit of the <span> and it’s attributes injected by Pinterest. In addition I found another post on another thread that was not so lucky. I’ve directed them here.

    Update: I submitted a ticket to Pinterest on 09/29/2017. They got back to me on 10/09/2017:

    Leila (Pinterest Help)
    Oct 9, 02:17 PDT

    Hi David,

    This is something I haven’t seen before but I’d be happy to look into this for you. To do so, I’ll need a little more info:

    The steps you took before running into trouble
    The exact error message you’re seeing (if any)
    Screenshots of what you’re seeing
    A link to the page where you’re having trouble
    I’d appreciate any additional information about the problem you’re experiencing, so we can dig into it and find a solution.

    Leila | Pinterest

    This issue was reported to me by a client. I did not have the Pinterest Save Button extension installed in my prefered browser, Chrome (Mac). So I installed it and set about creating a page to reproduce the issue. I could not.

    I did attempt to install the button in Safari too… but i found no Safari option other than a bookmarklet(?) Upon using the bookmarklet I found the option to ‘upgrade’ to the installable button.

    If any of you can provide the above information for Leila, I’d be happy to serve as proxy.

    I’ve reproduced it in Safari. Upon installing the extension, opening my test page to edit, the save button appeared over images in the editor as did the Save <span> appear in the [Text] tab.

    *For those of you who wish to continue to use Pinterest in Safari, I would recommend the bookmarklet until the extension is fixed.

    • This reply was modified 1 year, 6 months ago by  dwcouch. Reason: Noted absence of Safari button option
    • This reply was modified 1 year, 6 months ago by  dwcouch.
    • This reply was modified 1 year, 6 months ago by  dwcouch. Reason: Posted Conclusion after reproducing issue in Safari

    Thanks for reproducing this for Pinterest, @dwcouch! I look forward to hearing more (if more happens).

Viewing 15 replies - 1 through 15 (of 27 total)
  • The topic ‘Invisible html for background image appearing at bottom of posts/pages’ is closed to new replies.