Support » Fixing WordPress » Invalid WXR

  • I’m having a problem importing a blog to my host. My old will export in an xml file, but when I try to import this into WordPress, it says:

    Invalid File
    Please upload a valid WXR (WordPress eXtended RSS) export file.

Viewing 11 replies - 1 through 11 (of 11 total)
  • I understand that uses an XML format. From what I’ve gathered, WXR is just a form of xml, and wordpress should accept the import. Perhaps I need to convert it though?

    You shouldn’t.

    I just tested it: exported from and imported into a brand new 2.6.2 install. It works.


    I have the newest version of WordPress as well.

    Is there an alternative to importing the XML via HTTP, such as FTP perhaps?

    I have no idea.

    Alright, I’ve gotten a little further. I tried uploading a backup from one single author, which was a much smaller file. (I didn’t think this was an issue though, since I maximized the upload limit from 2MB to 20MB via .htaccess)

    It gave me this message:

    Unable to create directory /public_html/wp-content/uploads/2008/09. Is its parent directory writable by the server?

    Keep in mind, all permissions are 755. So I checked via FTP and no such folder was even created. I tried creating the folders, and now it’s telling me:

    The uploaded file could not be moved to /public_html/wp-content/uploads/2008/09.

    And writable is 777 (for wp-content)

    Should I set the upload folder to 777 then?

    Well, that worked… sort of. I managed to get a small xml file imported. This does me no good though because it wont accept 4MB file.

    On an unrelated note, after importing, wordpress spit out a bunch of these:

    set_time_limit() has been disabled for security reasons


    I fixed the size problem by compressing the archive to GZIP and uploading it.

    I’ve changed both my wp-content folder and the sub folder upload to 777 from their original 755. No luck.

    I’m using bluehost?

    Any suggestions?

    What kind of problems are you having with it? A little more information would be helpful. Make sure you have your upload limit high enough to allow your xml file to be imported. You can set that setting in your php.ini file. And make sure you have a copy of your php.ini file in your wp-content folder, or set your configuration to use your php.ini recursively.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Invalid WXR’ is closed to new replies.