WordPress.org

Ready to get started?Download WordPress

Forums

Invalid WXR (12 posts)

  1. intopuddles
    Member
    Posted 6 years ago #

    I'm having a problem importing a wordpress.com blog to my wordpress.org host. My old wordpress.com will export in an xml file, but when I try to import this into WordPress, it says:

    Invalid File
    Please upload a valid WXR (WordPress eXtended RSS) export file.

  2. intopuddles
    Member
    Posted 6 years ago #

    I understand that wordpress.com uses an XML format. From what I've gathered, WXR is just a form of xml, and wordpress should accept the import. Perhaps I need to convert it though?

  3. moshu
    Member
    Posted 6 years ago #

    You shouldn't.

    I just tested it: exported from wp.com and imported into a brand new 2.6.2 install. It works.

  4. intopuddles
    Member
    Posted 6 years ago #

    Hm...

    I have the newest version of WordPress as well.

    Is there an alternative to importing the XML via HTTP, such as FTP perhaps?

  5. moshu
    Member
    Posted 6 years ago #

    I have no idea.

  6. intopuddles
    Member
    Posted 6 years ago #

    Alright, I've gotten a little further. I tried uploading a backup from one single author, which was a much smaller file. (I didn't think this was an issue though, since I maximized the upload limit from 2MB to 20MB via .htaccess)

    It gave me this message:

    Unable to create directory /public_html/wp-content/uploads/2008/09. Is its parent directory writable by the server?

    Keep in mind, all permissions are 755. So I checked via FTP and no such folder was even created. I tried creating the folders, and now it's telling me:

    The uploaded file could not be moved to /public_html/wp-content/uploads/2008/09.

  7. moshu
    Member
    Posted 6 years ago #

    And writable is 777 (for wp-content)

  8. intopuddles
    Member
    Posted 6 years ago #

    Should I set the upload folder to 777 then?

  9. intopuddles
    Member
    Posted 6 years ago #

    Well, that worked... sort of. I managed to get a small xml file imported. This does me no good though because it wont accept 4MB file.

    On an unrelated note, after importing, wordpress spit out a bunch of these:

    set_time_limit() has been disabled for security reasons

  10. intopuddles
    Member
    Posted 6 years ago #

    update:

    I fixed the size problem by compressing the archive to GZIP and uploading it.

  11. nsolga
    Member
    Posted 6 years ago #

    I've changed both my wp-content folder and the sub folder upload to 777 from their original 755. No luck.

    I'm using bluehost?

    Any suggestions?

  12. BernardBorealis
    Member
    Posted 6 years ago #

    What kind of problems are you having with it? A little more information would be helpful. Make sure you have your upload limit high enough to allow your xml file to be imported. You can set that setting in your php.ini file. And make sure you have a copy of your php.ini file in your wp-content folder, or set your configuration to use your php.ini recursively.

Topic Closed

This topic has been closed to new replies.

About this Topic