Support » Plugin: SEO Plugin by Squirrly SEO » Invalid value [mpn] but the field is blank for product?

  • Resolved Lokesh Kumar

    (@lokesh22)


    Hi, We do not have MPN for cosmetics products. We have GTIN and we have applied it. The MPN field has been left blank on the woocommerce product page. Still, it is taking the mpn value in meta and the google merchant centre has rejected the entire product portfolio for this reason – Invalid value [mpn]

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Contributor Calin Vingan

    (@calinvingan)

    Hi @lokesh22,

    Thank you for the details.

    You find this option in Squirrly > SEO Settings > JSON-LD

    to avoid adding default data in JSON-LD, switch off the option:
    “Add default data for JSON-LD AggregateRating, Offers, Sku, MPN …”

    https://howto.squirrly.co/kb/json-ld-structured-data/#woocommerce

    Hope this helps,
    Calin

    Thread Starter Lokesh Kumar

    (@lokesh22)

    Actually this gives us the possibility to add GTIN. It is good, but if we are not applying anything in the MPN field, it should not reflect in the product page meta?

    If you are saying to switch off the entire thing, we will lose brand, GTIN, and reviews too.

    Plugin Contributor Calin Vingan

    (@calinvingan)

    This option “Add default data for JSON-LD AggregateRating, Offers, Sku, MPN …” is only adding the “-” value for the empty fields.

    If you switch this option off, Squirrly SEO will not add the empty fields in JSON-LD.

    This way you will see only the fields like GTIN for who you already have values.

    Thread Starter Lokesh Kumar

    (@lokesh22)

    Hi Calin,

    I have done as per your advice and will check if things are good. Thanks.

    Plugin Contributor Calin Vingan

    (@calinvingan)

    Awesome. Glad you made it.

    If you have a minute, please help us with a positive review.

    Thank you,
    Calin

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.