Support » Fixing WordPress » invalid URL in field “id”

Viewing 3 replies - 1 through 3 (of 3 total)
  • Moderator bcworkz


    In your first link, there is Yoast structured data where the “id” field’s URL includes an #article skip link, but there is no such element in the DOM. I think that is what Google is complaining about. Check the data you supplied to Yoast for this page and ensure any URLs are 100% correct. If Yoast auto-generates this field value, I suggest you ask through Yoast’s official support channel for guidance.



    i am trying now this plugin, maybe it will help: XML Sitemap & Google News and deactivated the yoast SEO setting for creating a sitemap

    Moderator bcworkz


    I was not very clear in my answer. The “id” error being flagged is not in the sitemap link, it’s in the structured data within the head section of the page. It appears to be placed there by Yoast. AFAIK deactivating Yoast sitemap functionality will not alter the structured data in the head section.

    Additionally, I misspoke about the #article skip link. My apologies. In the context it is used, it’s fine. It’s a RDF hash URI, not a skip link. Additionally, the Google structured data tool does not report any errors, or even warnings:

    It’s possible there was a transient error when Google crawled the page. I get errors flagged all the time that no longer exist and apparently never existed except the one time Google crawled.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘invalid URL in field “id”’ is closed to new replies.