WordPress.org

Ready to get started?Download WordPress

Forums

Invalid URL (9 posts)

  1. arizonalinda
    Member
    Posted 10 months ago #

    My URL recipegoldmine.recipes is returned at "invalid." Could it be because of the .recipes extension? If so, how can I use it?

  2. kjodle
    Member
    Posted 10 months ago #

    All I'm getting is that there is no content. Have you gotten this sorted?

  3. arizonalinda
    Member
    Posted 10 months ago #

    No, It still tells me that it is an invalid URL. I'm thinking it's because of the .recipes extension. There is nothing on the site yet. I'm afraid to work with the site until I get this problem solved.

  4. arizonalinda
    Member
    Posted 10 months ago #

    I'm getting this in the Settings > General section.

  5. arizonalinda
    Member
    Posted 10 months ago #

    The Site address you entered did not appear to be a valid URL. Please enter a valid URL.

  6. catacaustic
    very awesome
    Posted 10 months ago #

    Without looking at the processing, I'd be 99.999% sure that it's the .recipies TLD that you're using. This is something that you should report in Requests and Feedback so that the devs can see that it really does need to be changed with all of the new TLD's that are being added now.

    To keep you going for now, you should look at changing the URL directly in the database - http://codex.wordpress.org/Changing_The_Site_URL#Changing_the_URL_directly_in_the_database

    But... It looks like the site works now, so why do you want to change the URL? Or, are you trying to change some other settings on that page, but can't because of the URL that you're uisng, it becomes more of a problem. You can still follow the instructions in my first link above, but change the field name from home to whatever the field name is for the field that you want to update. Be warned that there's no validation doing it this way, so you do need to be careful.

  7. arizonalinda
    Member
    Posted 10 months ago #

    Specifically, it is these settings that are giving me a problem:

    WordPress Address (URL) http://www.recipegoldmine.recipes

    Site Address (URL) http://www.recipegoldmine.recipes
    Enter the address here if you want your site homepage to be different from the directory you installed WordPress.

    If I try to remove the URL under Site Address (as I do not want the home page to be different from the directory where I installed WP), then it give me the invalid URL error. I will follow your instructions. Thank you!

  8. catacaustic
    very awesome
    Posted 10 months ago #

    Both of those settings need to be there, and they should both be the same URL (in your case). There's no need to change anything there. If you do you'll just break everything!

  9. arizonalinda
    Member
    Posted 10 months ago #

    Thank you, catacaustic. I appreciate it.

Reply

You must log in to post.

About this Topic