WordPress.org

Forums

Blogger Importer
[resolved] Invalid Token error on importing Blogger (5 posts)

  1. matinl90
    Member
    Posted 9 months ago #

    I've had a blog on Blogger for some time and I just moved to a wordpress site.
    When I try to import my blogger posts this is what I get:

    "Howdy! This importer allows you to import posts and comments from your Blogger account into your WordPress site.
    To use this importer, you must have a Google account and an upgraded (New, was Beta) blog hosted on blogspot.com or a custom domain (not FTP).
    The first thing you need to do is tell Blogger to let WordPress access your account. You will be sent back here after providing authorization.

    Error occurred getting OAuth tokens from Google
    Invalid Token: Check server date, firewall settings and transports (curl, streams and fsockopen)"

    I don't even get to the authorization button. My firewall is off. I checked my servers date and it says UCT+0.00 and since I'm in Portugal it should be the same as my time expect that it's one hour earlier. Why is this happening? How can i change the time? Is this the problem? I tried reading a lot of stuff but my knowledge of wordpress is very basic. I don't even understand a lot of stuff. Today is my first day to even look at it. Can someone please help?? :(

    https://wordpress.org/plugins/blogger-importer/

  2. Samuel Wood (Otto)
    Tech Ninja
    Plugin Author

    Posted 9 months ago #

    Make sure that your server is actually set to the correct time.

    A surprising amount of security is based on time. It's not the timezone that you're in, but that your server agrees with every other server in the world as to what the current time is. If it is even a few minutes off, then the tokens won't work because they're based on a shared idea of accurate time measurement.

    So, set your server's time to be correct. As much as 3 minutes off is too much.

  3. matinl90
    Member
    Posted 9 months ago #

    I got in contact with my host customer service and they told me the time zone is not changeable and that the problem is not for that. They said it's the plugin. So now I don't know what to do!

  4. matinl90
    Member
    Posted 9 months ago #

    Ok, it's solved now. Thanks for getting back to me :)

  5. myheartswift
    Member
    Posted 8 months ago #

    how did you solve it matinl90? i am completely stuck. can you please help me?

Reply

You must log in to post.

About this Plugin

About this Topic