Support » Plugin: Stripe Payments » Invalid stripe token only in mobile

  • Resolved mmeida

    (@mmeida)



    Hi. The plugin works fine in desktop, but not in mobile (Safari, iPhone). When the user enters the amount and presses the button, the message ‘The system could not complete the payment. Invalid Stripe Token’ appears.

    Cause it works in desktop, I assume that the setting are are ok.

    Regards.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 22 total)
  • Plugin Support mbrsolution

    (@mbrsolution)

    Hi, I actually tested this in my android phone and on my laptop browser and I get the same error message.

    Do you have a cache plugin installed in your site? If you do, did you exclude the plugins cart page?

    Regards

    mmeida

    (@mmeida)

    Yes, Wp Rocket and I’ve excluded the URL but no change.

    Plugin Support mbrsolution

    (@mbrsolution)

    Hi, can you carry out the following. Disable all of your other plugins including Wp Rocket and carry out a test.

    Let me know what happens.

    Thank you

    • This reply was modified 10 months ago by  mbrsolution.
    mmeida

    (@mmeida)

    Well, I’ve located the plugin that creates problems. This is Yoast SEO, can you believe it? How can this affect, if this is supposed to work in the backend?

    Plugin Support mbrsolution

    (@mbrsolution)

    It is hard to believe because the developers stated in another post that Yoast SEO does work with this plugin. There must be some other configuration in your site that might be causing this issue. I wonder if it is your theme. Try one of WordPress default themes like Twenty Sixteen or Seventeen. Let me know what happens.

    Thank you.

    mmeida

    (@mmeida)

    Sorry, but my site is active and I can not disable the theme. In fact, the Stripe plugin works perfectly now with the theme. I have disabled all the plugins and I have been activating them one by one until I have verified that Yoast SEO is causing the problem. If the theme somehow affected the plugin, I suppose it would in any circumstance. True?

    Plugin Support mbrsolution

    (@mbrsolution)

    Yes you could be right. Then that means your issue with this plugin is resolved since it is not related to this plugin.

    You should contact Yoast support team and let them know the issue you are having.

    Let us know what they say?

    Thank you

    • This reply was modified 10 months ago by  mbrsolution.
    mmeida

    (@mmeida)

    Ok. Thanks four your support.

    Regards.

    Plugin Contributor Alexander C.

    (@alexanderfoxc)

    Yoast is very protective for their creation and most of their replies can be translated as “you’re doing it wrong. closed.” 🙂 So I made some amendments to Stripe Payments plugin to make it live peacefully with Yoast SEO.

    I’m marking this thread as resolved. If you still having issues with Yoast SEO plugin, please post them here.

    mmeida

    (@mmeida)

    Hi, @alexanderfoxc. Thanks for your work. My problem is still there, Yoast SEO blocks the Stripe initial form.

    Regards.

    Plugin Contributor Alexander C.

    (@alexanderfoxc)

    Hi @mmeida.

    Are you using the latest version of the plugin (1.7.1 at the moment)?

    mmeida

    (@mmeida)

    Yes, @alexanderfoxc: Stripe 1.7.1 and Yoast 6.1.1. I’ve also erased the WP Rocket cache and OPcache. but no changes.

    Plugin Contributor Alexander C.

    (@alexanderfoxc)

    Looks like on mobile version, you got some javascript errors. Stripe Payments is very sensitive to those, and if something else is breaking JS execution, it can’t operate normally.

    I think this is related to some plugin that tries to make AMP pages when viewing website from mobile phone. Is it possible to exclude the page with the button from this plugin?

    mmeida

    (@mmeida)

    Yes, it’s Accelerated Mobile Pages 0.9.73, but there is not setting to exclude an URL.

    Plugin Contributor Alexander C.

    (@alexanderfoxc)

    Go to page edit and look at the right column, there should be a box saying “Show AMP for Current Page?”. Select “Hide” option there and save the page, then clear plugins cache and try again from your mobile.

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘Invalid stripe token only in mobile’ is closed to new replies.