Support » Plugin: WP-CalDav2ICS » Invalid Server response

  • Hallo!
    Da ich mehrere CalDav-Kalender in einer WordPress-Umgebung veröffentlichen will, sind die zwei Plugins von hoernerfranz genau das was ich gesucht habe.
    Leider bekomme ich in meinem Setting (nextcloud als CalDav-Server) zu keinem Ergebnis.
    Das Log-File gibt folgendes Ergebnis:
    (Originallink habe ich verändert)

    Log created on 19:01:28 11:12:56
    CalendarURL:http://nextcloud.myserver.de/remote.php/dav/
    <?xml version="1.0" encoding="utf-8"?>
    <d:error xmlns:d="DAV:" xmlns:s="http://sabredav.org/ns">
      <s:exception>Sabre\DAV\Exception\ReportNotSupported</s:exception>
      <s:message/>
      <d:supported-report/>
    </d:error>
    Tag://cal:calendar-data
    <?xml version="1.0" encoding="utf-8"?>
    <d:error xmlns:d="DAV:" xmlns:s="http://sabredav.org/ns">
      <s:exception>Sabre\DAV\Exception\ReportNotSupported</s:exception>
      <s:message/>
      <d:supported-report/>
    </d:error>

    Ich habe das Plugin heute installiert, müsste somit das aktuelle 1.0.4 sein (im Backend wird 1.0 angezeigt?).

    Liegt das an der noch nicht vorhandenen nextcloud-Unterstützung? Oder ist mein Link nicht korrekt?
    Einen Zugang zu meiner nextcloud-Installation kann ich zur Verfügung stellen.

    Viele Grüße,
    Jonas

Viewing 13 replies - 1 through 13 (of 13 total)
  • Thread Starter Jonas Jozwiak

    (@norgey)

    Inhalt der ICS-Datei:
    ERROR: Your Server's response is invalid and cannot be parsed - please enable Logging and check the Logfile !

    Plugin Author hoernerfranz

    (@hoernerfranz)

    hi Jonas,
    das sieht nicht so gut aus, entscheidend ist diese Zeile der Server-Antwort:
    exception>Sabre\DAV\Exception\ReportNotSupported

    das sieht so aus als ob der Server nicht dafür konfiguriert ist, den auf den request angeforderten Report zu liefern.

    vllt. ist aber auch nur die URL:
    http://nextcloud.myserver.de/remote.php/dav/
    falsch.
    (es gibt ja WebDav, CalDav und CardDav, evtl. muss man hier gezielt den CalDav Service ansprechen).
    Am besten erstmal mit einem CalDav Client (z.b. Thunderbird mit Lightning Plugin) verifizieren !

    • This reply was modified 3 years, 10 months ago by hoernerfranz.
    Thread Starter Jonas Jozwiak

    (@norgey)

    Hallo Werner,
    vielen Dank für die schnelle Antwort.
    Es war natürlich mein Fehler… die URL war nicht die richtige. Nun wird eine ICS-Datei mit Inhalt erstellt!
    Gibt es eine Möglichkeit, mehrere unabhängige Kalender zu erstellen?

    Jetzt muss nur der Import in deinem WP ICS Importerer klappen und die dazugehörige Darstellung in WordPress. Da arbeite ich gerade dran.

    Grüße, Jonas

    Plugin Author hoernerfranz

    (@hoernerfranz)

    ok, prima 😀 .
    und nein, das Plugin kann momentan nur EINEN Kalender erstellen, ich habe aber schon drangedacht, das evtl. mal zu erweitern.
    Mal sehen, vielleicht mache ich das irgendwann …
    Ansonsten kann der ICS Importer natürlich die so erzeugten Kalender anzeigen,
    das mache ich ja selber auch so.
    Ich schliesse nun dieses Ticket hier.
    Gruss
    Werner

    Hallo,

    ich habe das gleiche Problem. Jonas hatte entdeckt das er den falschen Link angegeben hatte. Welcher ist denn der richtige. Ich bekomme das hier mit Nextcloud auch nicht gebacken.

    lg Smorfy

    Thread Starter Jonas Jozwiak

    (@norgey)

    In der Kalenderansicht von nextcloud auf die drei Punkte bei dem gewünschten Kalender klicken, dann auf “Link”. Jetzt wird der passende Link angezeigt.
    Beispielsweise:
    http://nextcloud.my-server.de/remote.php/dav/calendars/user/calendarname/
    Hoffe, das hilft weiter.

    Grüße, norgey

    Plugin Author hoernerfranz

    (@hoernerfranz)

    also am besten mal den Jonas fragen 😀 – er hat mir seine richtige URL nicht genannt…
    aber so wie ich bisher mitbekommen habe, heisst die richtige URL bei Nextcloud etwa so:
    https://your-next.cloud.server/remote.php/dav/principals/users/username/kalendername
    Server, username und kalendername sind nat. individuell verschieden.
    <edit>
    der Jonas hat grad auch geantwortet, wie ich sehe 🙂
    damit sollte es dann klappen….
    </edit>

    • This reply was modified 3 years, 8 months ago by hoernerfranz.

    Danke Leute,
    kaum nimmt man den richtigen Link, und schon gehts.

    Und kaum ist das eine Problem erledigt, kommt auch schon das nächste um die Ecke. Bei den Einstellungen im Plugin, kann man mehrere Kalender eingeben, die er dann auch brav konvertiert. Aber den Stündlichen Cron Job macht er nur für einen Kalender, oder?

    Kann ich auch drei Kalender gleichzeitig konvertieren?

    lg, Smorfy

    Plugin Author hoernerfranz

    (@hoernerfranz)

    hm,
    da war wohl ein fclose() hinter der falschen Klammer 😀 .
    sollte jetzt gehen, neue Version ist auf GitHub.
    Bitte mal ausprobieren und Rückmeldung.
    (Im Prinzip reicht der Austausch der Datei Caldav2ics_Plugin.php aus dem Repository)

    • This reply was modified 3 years, 8 months ago by hoernerfranz.

    Hallo hoernerfranz,

    also es geht schon mal in die richtige Richtung.

    Habe dein Plugin upgedatet. Jedoch bekomme ich nur Fehlermeldungen, wenn ich nur die eine .php datei uploade. Erst als komplettes .zip File von deiner Github Seite nimmt er die Neufassung (Ich hoffe diese Info ist für dich auch wichtig).

    Jetzt funktionieren 2 Kalender. Beim 3ten Kalender, kommt folgende Fehlermeldung:
    ERROR: Your Server’s response is invalid and cannot be parsed – please enable Logging and check the Logfile !

    Ich habe den 3ten Kalender auch mal als 2ten eingetragen, und nur bei 2 Kalendern, funktioniert das super! Nachdem ich nun nicht mehr weiß, was ich noch falsch gemacht haben kann, hoffe ich auf noch eine Klammer bei dir :-)!

    lg Smorfy

    Plugin Author hoernerfranz

    (@hoernerfranz)

    Also ich kann das Problem nicht nachvollziehen – habe es hier mit 3 und auch mit 4 Kalendern getestet, funktioniert einwandfrei, sowohl direkt beim Speichern als auch beim geplanten cron-schedule.
    Wobei das auch vor dem genannten fclose() Fix funktioniert hat, was allerdings etwas unsauber war, da ich dort diese Funktion noch der automatischen Garbage Collection überlassen hatte 😀 .
    Und das Update nur mit der ausgetauschten php Datei hätte auch funktionieren müssen, denn die 2 sonstigen Änderungen waren nur im readme.txt und in der Versionsnummer – beides hat mit der Funktion nichts zu tun.
    War das vorher vllt. noch eine ältere Version ( < 1.1.0 ) ?
    Und beim Update von Github auch alles richtig gemacht, wie beschrieben ?

    Wie auch immer, ich habe nun die Version im WP Directory auf 1.1.1 aktualisiert, mal sehen ob da noch andere Rückmeldungen kommen…

    P.S.:
    dieser Thread hier war schon geschlossen, da erledigt.
    Falls es weiter Probleme gibt: einen neuen erstellen, und zwar in Englisch, das hier ist ein internationales Support Forum, da lesen auch Leute mit die kein Deutsch sprechen.

    Hallo hoernerfranz,

    auch wenn schon geschlossen, die Rückmeldung sollte hier noch hin. Ich Danke für deine Bemühungen. Nachdem es bei mir immer noch nicht ging, habe ich meine 3 Nextcloud Kalender gelöscht und neu angelegt. Diesmal als Kalender Namen nur aus einem Wort bestehend, also ohne Leerzeichen wie vorher. Und was soll ich sagen, jetzt geht das. Stellt sich mir nur die Frage ob es schon immer daran gelegen hat.

    Ich kann nur noch einmal erwähnen, das ich sehr dankbar für Deine Bemühungen bin.

    lg Smorfy

    Plugin Author hoernerfranz

    (@hoernerfranz)

    freut mich, Smorfy, dass es jetzt klappt 😀 – und ja: Leerzeichen in Datei/Ordnernamen und besonders in URL’s (etwas anderes ist das ja schlussendlich nicht) sind Gift und gehören verboten ;-).
    (Man könnte sie ggf. maskieren, mit % Zeichen und so, aber viel besser ist eben ohne !).
    Der letzte Fix mit dem fclose() ist aber dennoch sinnvoll, weil einfach sauberer.
    Deswegen bleibt er auch drin.
    Und danke für die Rückmeldung.
    Der Thread ist damit endgültig geschlossen 😀 .
    Gruss
    Werner

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Invalid Server response’ is closed to new replies.